Last Comment Bug 739387 - Aurora 13a New Tab display doesn't allow javascript bookmarks to be selected
: Aurora 13a New Tab display doesn't allow javascript bookmarks to be selected
Status: RESOLVED DUPLICATE of bug 728313
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 13 Branch
: All All
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 13:50 PDT by Emily Shirley
Modified: 2012-06-28 13:52 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Emily Shirley 2012-03-26 13:50:10 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20120324 Firefox/13.0a2
Build ID: 20120324042010

Steps to reproduce:

I use several Javascript bookmarks in my bookmarks toolbar and they no longer work in when selected on a new tab under Aurora 13a. An example of such a bookmark would be:

   javascript:x=escape(getSelection());if(!x)%7Bvoid(x=prompt('Search%20Wikipedia%20for?',''))%7D;window.location='http://en.wikipedia.org/wiki/Special:Search?search='+x+'&go=Go'

They work everywhere else without problems, just not on newly opened tabs with the new New Tab display.


Actual results:

Nothing happens when a Javascript bookmark is clicked.


Expected results:

It should have opened a dialogue asking for a search term, passing that on to the site in the URL in the latter part of the contents.
Comment 1 Alice0775 White 2012-03-26 16:01:37 PDT
Confirmed in
http://hg.mozilla.org/mozilla-central/rev/ba4983d9c1f9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120326 Firefox/14.0a1 ID:20120326031149
Comment 2 Virgil Dicu [:virgil] [QA] 2012-03-27 04:59:08 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120315 Firefox/13.0a2

Setting to new. Loading the bookmarked URL in new tab doesn't work in F13 Aurora.
Comment 3 Brent Kelly 2012-06-18 15:17:43 PDT
Happens in Win7 + Firefox 13.0.1
Comment 4 Colin Guthrie 2012-06-25 02:24:38 PDT
Yup, happening here too (Mageia Linux 64bit 13.0.1). I thought it was broken generally, but I now see it's only on the new tab page with the fancy common sites thingy.

I have a few js bookmarks, some for keyword searches for sites where simple %s replacements are not enough, where this can get quite annoying as it's typically on the new tab page where I use these.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-25 10:20:51 PDT

*** This bug has been marked as a duplicate of bug 728313 ***

Note You need to log in before you can comment on or make changes to this bug.