Last Comment Bug 739432 - .inplaceEditor expandos on content objects aren't visible cross-global in a compartment-per-global world
: .inplaceEditor expandos on content objects aren't visible cross-global in a c...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Style Editor (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
: Gabriel Luong [:gl][1 biz day review guarantee] (ΦωΦ)
Mentors:
Depends on:
Blocks: cpg
  Show dependency treegraph
 
Reported: 2012-03-26 15:10 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-03-27 05:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Access the inplaceEditor expando with an explicit API. v1 (15.84 KB, patch)
2012-03-26 15:15 PDT, Bobby Holley (:bholley) (busy with Stylo)
dcamp: review+
Details | Diff | Splinter Review

Description Bobby Holley (:bholley) (busy with Stylo) 2012-03-26 15:10:31 PDT
I discussed this with dcamp over email. The issue is that chrome expandos on content objects go on the xray wrapper expando object, which is per-compartment. So with cross-global access (ie, outside the JSM), the inplaceEditor expando is invisible.

Patch coming right up.
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2012-03-26 15:15:30 PDT
Created attachment 609508 [details] [diff] [review]
Access the inplaceEditor expando with an explicit API. v1

Attaching a patch. Flagging dcamp for review.
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-03-26 15:28:39 PDT
Pushed to m-i: http://hg.mozilla.org/integration/mozilla-inbound/rev/d211c6492297
Comment 3 Ed Morley [:emorley] 2012-03-27 05:23:34 PDT
https://hg.mozilla.org/mozilla-central/rev/d211c6492297

Note You need to log in before you can comment on or make changes to this bug.