If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bad timestamp in message filter logs for deleted messages

RESOLVED DUPLICATE of bug 762318

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 762318
6 years ago
4 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I enabled message filter logs because I was having a problem with messages seeming not being caught by filters. I noticed some of the log entries have invalid timestamps.

  Applied filter "xxx" to message from - at 12/31/69 4:00:00 PM deleted

Seems to only happen to entries for deleted messages. Other entries are fine:

  Applied filter "yyy" to message from zzz - blahblah at 3/26/12 3:33:21 PM marked as read

Comment 1

6 years ago
What is the TB version?
When I now ran a delete filter manually on a folder, I actually didn't get any message in the filter log.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: unspecified → Trunk
(Reporter)

Comment 2

6 years ago
TB 12.

Comment 3

6 years ago
Wayne, can you reproduce this?
Version: Trunk → 12
I'd need Dolske's steps.

Justin, are you using delete model?  What are your steps?
(In reply to Justin Dolske [:Dolske] from comment #0)
>   Applied filter "xxx" to message from - at 12/31/69 4:00:00 PM deleted

What is Date: header of the filtered mail?
If POP3 folder of folder of Local Folders, what is written in first "From - ..." line of message source of the filtered mail?

What is condition of filter rule named "xxx" which deleted the mail?
Is it for ordinal/required mail for you? Or for smap like mail?

(In reply to :aceman from comment #1)
> When I now ran a delete filter manually on a folder, I actually didn't get
> any message in the filter log.

Phenomenon which can be observed with bug 695671?
(Reporter)

Comment 6

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> I'd need Dolske's steps.
> 
> Justin, are you using delete model?  What are your steps?

"Delete model"?

I was just seeing this with a plain old deletion filter.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762318
You need to log in before you can comment on or make changes to this bug.