intermittent editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html | Editor4, html and div has contenteditable attribute: wrong element was edited - got , expected a

RESOLVED FIXED in mozilla14

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: mak, Assigned: masayuki)

Tracking

({intermittent-failure})

Trunk
mozilla14
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=10393524&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=10393091&tree=Mozilla-Inbound

21178 INFO TEST-PASS | /tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html | Editor3, div has contenteditable attribute: input event by Redo wasn't trusted event
21179 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html | Editor4, html and div has contenteditable attribute: wrong element was edited - got , expected a
21180 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html | Editor4, html and div has contenteditable attribute: input event wasn't fired by 'a' key
21181 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html | an unexpected uncaught JS exception reported through window.onerror - inputEvent is null at http://mochi.test:8888/tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html:72
JavaScript error: http://mochi.test:8888/tests/editor/libeditor/html/tests/test_dom_input_event_on_htmleditor.html, line 72: inputEvent is null
OS: Windows 7 → Windows XP
Hardware: x86_64 → x86
Blocks: 668606
Hmm, it's strange. Why sometimes failed to set focus? (or to set caret position in the div element?)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 5

7 years ago
Sometimes I've seen weird behavior when you focus the contentWindow of an iframe but not the iframe itself.  Could you please submit a patch to focus the iframe itself before focusing the contentWindow?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
All of them failed at testing editor 4, I'll investigate it.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Depends on: 739927
Posted patch PatchSplinter Review
I think that I misunderstood the Element.focus() behavior. It shouldn't work with non-editing host element. But the test sets focus to its window, that causes sometimes working fine. I'm still not sure why it fails randomly, however, I think that setting focus to the editing host and setting caret position by document.getSelection().collapse(), it works fine.

I tested on try server:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=1765e9b2e142
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Attachment #610470 - Flags: review?(ehsan)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Updated

7 years ago
Attachment #610470 - Flags: review?(ehsan) → review+
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(In reply to TinderboxPushlog Robot from comment #37)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10480734&tree=Mozilla-
> Inbound
> Rev3 WINNT 5.1 mozilla-inbound pgo test mochitests-3/5 on 2012-03-29 12:29:47

This is before the landing.
(In reply to TinderboxPushlog Robot from comment #35)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10477412&tree=Mozilla-
> Inbound
> Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-3/5 on 2012-03-29
> 10:10:45

This is also before the landing. If we saw this failure on m-i after now, the patch failed to fix this bug.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 45

7 years ago
https://hg.mozilla.org/mozilla-central/rev/f059dc47f3d7
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange]
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.