Closed Bug 739601 Opened 8 years ago Closed 5 years ago

Replace config/milestone.pl

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla37

People

(Reporter: joey, Assigned: Ms2ger)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Port config/milestone.pl to python and write unit a unit test for the script.
   - the .pl script will also generate an uninit var warning when called w/o --topsrcdir.

toolkit/xre/Makefile.in - this makefile is setup to read milestone.txt in different ways {stale code?}.  Calling milestone.pl and cat config/milestone.txt.  Cat should be replaced by a call to the script so whitespace and embedded newlines cannot affect extracting a value from the file.
I'm not sure why we read the file in two ways, but it may be that certain locations actually want the full version number there. milestone.pl simply strips off the trailing bits (like "a1"), which seems like hugely overkill at this point. Perhaps it did more in an ancient time, I can't remember.
It probably made sense when we had versions like x.ya1pre.
Summary: config/milestone.pl → Replace config/milestone.pl
Duplicate of this bug: 941299
Assignee: nobody → Ms2ger
Comment on attachment 8542902 [details] [diff] [review]
Rewrite (the used parts of) config/milestone.pl in python

Review of attachment 8542902 [details] [diff] [review]:
-----------------------------------------------------------------

Most excellent.
Attachment #8542902 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/9b33fc49396c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.