Assertion failure: count == 0 || start < Length() (Invalid start index) in nsTArray<nsAHttpTransaction*, nsTArrayDefaultAllocator>::RemoveElementsAt

RESOLVED DUPLICATE of bug 741056

Status

()

Core
Networking
--
critical
RESOLVED DUPLICATE of bug 741056
6 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression})

Trunk
x86
Mac OS X
assertion, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
1. https://confluence.corp.netspend.com/display/dev/SL%2B-%2BProcess%2BProprietary%2BPayroll%2BFiles%2B%28Fixed%2BLength%2Band%2BTab-Delimited%29

2. Nightly/14 Mac 

Assertion failure: count == 0 || start < Length() (Invalid start index), at ../../../dist/include/nsTArray.h:941


#0  0x00018dcd in MOZ_Crash () at /work/mozilla/builds/nightly/mozilla/mfbt/Assertions.cpp:76
#1  0x00018e37 in MOZ_Assert (s=0x79f83f8 "count == 0 || start < Length() (Invalid start index)", file=0x79f8378 "../../../dist/include/nsTArray.h", ln=941) at /work/mozilla/builds/nightly/mozilla/mfbt/Assertions.cpp:88
#2  0x05960b78 in nsTArray<nsAHttpTransaction*, nsTArrayDefaultAllocator>::RemoveElementsAt (this=0x245d7b7c, start=0, count=1) at nsTArray.h:941
#3  0x05960c20 in nsTArray<nsAHttpTransaction*, nsTArrayDefaultAllocator>::RemoveElementAt (this=0x245d7b7c, index=0) at nsTArray.h:949
#4  0x0596056c in nsHttpPipeline::WriteSegments (this=0x245d7b60, writer=0x245d78e4, count=32768, countWritten=0xb01a4be0) at /work/mozilla/builds/nightly/mozilla/netwerk/protocol/http/nsHttpPipeline.cpp:768
#5  0x05914c04 in nsHttpConnection::OnSocketReadable (this=0x245d78e0) at /work/mozilla/builds/nightly/mozilla/netwerk/protocol/http/nsHttpConnection.cpp:1368
#6  0x05915d80 in nsHttpConnection::OnInputStreamReady (this=0x245d78e0, in=0x24470910) at /work/mozilla/builds/nightly/mozilla/netwerk/protocol/http/nsHttpConnection.cpp:1488
#7  0x0586df23 in nsSocketInputStream::OnSocketReady (this=0x24470910, condition=0) at /work/mozilla/builds/nightly/mozilla/netwerk/base/src/nsSocketTransport2.cpp:256
#8  0x0586e14c in nsSocketTransport::OnSocketReady (this=0x24470820, fd=0x23e376f0, outFlags=1) at /work/mozilla/builds/nightly/mozilla/netwerk/base/src/nsSocketTransport2.cpp:1575
#9  0x05875ab6 in nsSocketTransportService::DoPollIteration (this=0x133d30, wait=true) at /work/mozilla/builds/nightly/mozilla/netwerk/base/src/nsSocketTransportService2.cpp:762
#10 0x05875dd8 in nsSocketTransportService::Run (this=0x133d30) at /work/mozilla/builds/nightly/mozilla/netwerk/base/src/nsSocketTransportService2.cpp:645

Beta, Aurora fail to load the page. 

XP aborts with an unrelated abort. Linux fails to load the page.

Opt build fails to load the page.
(Reporter)

Updated

6 years ago
Severity: normal → critical
Blocks: 739762
bob, is there a proxy involved?
I can't get a stack or abort out of this test case - even using a debug os x nightly from 3/26 which would seem to be about right. I just get a failure to load the page, which is expected. I'll try windows next just to be thorough.

Even if there isn't a proxy involved, I think the patch from 741056 would address this stack trace. Bob, can you test the try build linked below and report on that?

https://bugzilla.mozilla.org/show_bug.cgi?id=741056#c17
(Reporter)

Comment 3

6 years ago
I can't resolve the host any more.
(In reply to Bob Clary [:bc:] from comment #3)
> I can't resolve the host any more.

Ah - I couldn't either. I thought that's what you meant by page fails to load.

Given that fact, and the fact that the stack touches the same code as the patch for 741056 I'm going to mark this a dup as the most likely disposition...let me know if that doesn't make sense to you.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741056
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.