Last Comment Bug 739706 - gfxFont.cpp compiler warnings on OSX
: gfxFont.cpp compiler warnings on OSX
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: John Daggett (:jtd)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 11:20 PDT by John Daggett (:jtd)
Modified: 2012-03-31 19:33 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, fix warnings (2.09 KB, patch)
2012-03-27 11:23 PDT, John Daggett (:jtd)
jfkthame: review+
Details | Diff | Splinter Review

Description John Daggett (:jtd) 2012-03-27 11:20:31 PDT
Under OSX, gfxFont.cpp generates compile warnings:

/builds/mozcentral/gfx/thebes/gfxFont.cpp: In member function ‘bool gfxFont::SplitAndInitTextRun(gfxContext*, gfxTextRun*, const T*, PRUint32, PRUint32, PRInt32) [with T = PRUint8]’:
/builds/mozcentral/gfx/thebes/gfxFont.cpp:3381:   instantiated from ‘void gfxFontGroup::InitScriptRun(gfxContext*, gfxTextRun*, const T*, PRUint32, PRUint32, PRInt32) [with T = PRUint8]’
/builds/mozcentral/gfx/thebes/gfxFont.cpp:3282:   instantiated from ‘void gfxFontGroup::InitTextRun(gfxContext*, gfxTextRun*, const T*, PRUint32) [with T = PRUint8]’
/builds/mozcentral/gfx/thebes/gfxFont.cpp:3206:   instantiated from here
/builds/mozcentral/gfx/thebes/gfxFont.cpp:2216: warning: comparison is always false due to limited range of data type
/builds/mozcentral/gfx/thebes/gfxFont.cpp:2294: warning: comparison is always true due to limited range of data type
Comment 1 John Daggett (:jtd) 2012-03-27 11:23:49 PDT
Created attachment 609804 [details] [diff] [review]
patch, fix warnings
Comment 2 Jonathan Kew (:jfkthame) 2012-03-30 09:08:20 PDT
Comment on attachment 609804 [details] [diff] [review]
patch, fix warnings

Review of attachment 609804 [details] [diff] [review]:
-----------------------------------------------------------------

Seems fine.
Comment 3 John Daggett (:jtd) 2012-03-30 13:45:21 PDT
Pushed to inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/7cf8fc503806
Comment 4 Ed Morley [:emorley] 2012-03-31 19:33:01 PDT
https://hg.mozilla.org/mozilla-central/rev/7cf8fc503806

Note You need to log in before you can comment on or make changes to this bug.