Closed Bug 739767 Opened 8 years ago Closed 8 years ago

Empty graphics blocklist fields should not generate no nodes instead of empty XML nodes

Categories

(Toolkit :: Blocklist Policy Requests, defect, P1, blocker)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: jorgev, Unassigned)

References

()

Details

This is apparently blocking bug 722538, which we have been iterating on for a long time. The problem is that we're sending this:

> <driverVersion></driverVersion>
> <driverVersionComparator></driverVersionComparator>

Both fields are empty in the admin form (see URL). Apparently Firefox handles empty nodes differently than no nodes and the blocklist item doesn't work. We need that empty fields in the form translate to no nodes in the XML.

Bug 639723 is a similar bug that was fixed by changing the DB entry manually, so we should look into this for a short-term solution. This bug shouldn't be closed until we fix the problem on the admin tools, though.
Closing based on comment 1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.