assertions when loading a folder with only one thread.

VERIFIED FIXED

Status

MailNews Core
Backend
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Navin Gupta, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
To reproduce

1)Send 4 messages of the order of 500kb to your POP account
2)Receive them in your inbox. 
3)close mail
4)Reopen mail, mail crashes

stack trace

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x0536cb9c, const char * 0x0536ca98, const char 
* 0x0536ca6c, int 78) line 286 + 13 bytes
mork_assertion_signal(const char * 0x0536cb9c) line 78 + 31 bytes
morkEnv::NewWarning(const char * 0x0536c9c4) line 381 + 19 bytes
morkNode::RefsOverflowWarning(morkEnv * 0x04f1cce0) line 328
morkNode::AddWeakRef(morkEnv * 0x04f1cce0) line 576
morkNode::SlotWeakNode(morkNode * 0x040ab4e8, morkEnv * 0x04f1cce0, morkNode * * 
0x00b6b050) line 468 + 18 bytes
morkStore::SlotWeakStore(morkStore * 0x040ab4e8, morkEnv * 0x04f1cce0, morkStore 
* * 0x00b6b050) line 400 + 20 bytes
morkRowObject::morkRowObject(morkEnv * 0x04f1cce0, const morkUsage & {...}, 
nsIMdbHeap * 0x04f19de0, morkRow * 0x040ac498, morkStore * 0x040ab4e8) line 86 + 
20 bytes
morkRow::AcquireRowObject(morkEnv * 0x04f1cce0, morkStore * 0x040ab4e8) line 257 
+ 58 bytes
morkRow::AcquireRowHandle(morkEnv * 0x04f1cce0, morkStore * 0x040ab4e8) line 267 
+ 16 bytes
orkinTable::GetMetaRow(nsIMdbEnv * 0x04f1cf28, const mdbOid * 0x00000000, mdbOid 
* 0x00000000, nsIMdbRow * * 0x00b6c7c4) line 530 + 19 bytes
nsMsgThread::nsMsgThread(nsMsgDatabase * 0x04f1b1e0, nsIMdbTable * 0x04f671b8) 
line 47
nsMsgDBThreadEnumerator::PrefetchNext() line 2405 + 38 bytes
nsMsgDBThreadEnumerator::HasMoreElements(nsMsgDBThreadEnumerator * const 
0x00b68f30, int * 0x0012af58) line 2434
nsMsgThreadedDBView::ListThreadIds(unsigned int * 0x0012b6a8, int 0, unsigned 
int * 0x0012b37c, int * 0x0012af94, char * 0x0012b2b4, int 200, int * 
0x0012b69c, int * 0x00000000) line 208 + 45 bytes
nsMsgThreadedDBView::InitThreadedView(int * 0x0012b8c4) line 79 + 69 bytes
nsMsgThreadedDBView::Open(nsMsgThreadedDBView * const 0x04f179c0, nsIMsgFolder * 
0x026b64dc, int 18, int 1, int 0, int * 0x0012b8c4) line 48
XPTC_InvokeByIndex(nsISupports * 0x04f179c0, unsigned int 3, unsigned int 5, 
nsXPTCVariant * 0x0012b884) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x026ba210, 
nsXPCWrappedNative * 0x04ee8620, const XPCNativeMemberDescriptor * 0x04f1756c, 
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 5, long * 
0x04088194, long * 0x0012ba6c) line 934 + 42 bytes
WrappedNative_CallMethod(JSContext * 0x026ba210, JSObject * 0x04004da0, unsigned 
int 5, long * 0x04088194, long * 0x0012ba6c) line 250 + 34 bytes
js_Invoke(JSContext * 0x026ba210, unsigned int 5, unsigned int 0) line 781 + 23 
bytes
js_Interpret(JSContext * 0x026ba210, long * 0x0012c7ec) line 2674 + 15 bytes
js_Invoke(JSContext * 0x026ba210, unsigned int 2, unsigned int 2) line 798 + 13 
bytes
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJSClass * const 0x04eec560, 
nsXPCWrappedJS * 0x04eec4c0, unsigned short 10, const nsXPTMethodInfo * 
0x00d999ac, nsXPTCMiniVariant * 0x0012cc54) line 874 + 21 bytes
nsXPCWrappedJS::CallMethod(nsXPCWrappedJS * const 0x04eec4c0, unsigned short 10, 
const nsXPTMethodInfo * 0x00d999ac, nsXPTCMiniVariant * 0x0012cc54) line 432
PrepareAndDispatch(nsXPTCStubBase * 0x04eec4c0, unsigned int 10, unsigned int * 
0x0012cd04, unsigned int * 0x0012ccf4) line 100 + 31 bytes
SharedStub() line 124
nsMsgMailSession::OnItemEvent(nsMsgMailSession * const 0x04951714, nsIFolder * 
0x026b64dc, nsIAtom * 0x026b6960) line 299
nsMsgFolder::NotifyFolderEvent(nsMsgFolder * const 0x026b64dc, nsIAtom * 
0x026b6960) line 2383
nsMsgLocalMailFolder::GetDatabase(nsIMsgWindow * 0x04801480) line 569
nsMsgLocalMailFolder::UpdateFolder(nsMsgLocalMailFolder * const 0x026b64dc, 
nsIMsgWindow * 0x04801480) line 583 + 19 bytes
XPTC_InvokeByIndex(nsISupports * 0x026b64dc, unsigned int 40, unsigned int 1, 
nsXPTCVariant * 0x0012cfbc) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x026ba210, 
nsXPCWrappedNative * 0x04ec26a0, const XPCNativeMemberDescriptor * 0x00ddbe64, 
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 1, long * 
0x04087f34, long * 0x0012d1a4) line 934 + 42 bytes
WrappedNative_CallMethod(JSContext * 0x026ba210, JSObject * 0x04004970, unsigned 
int 1, long * 0x04087f34, long * 0x0012d1a4) line 250 + 34 bytes
js_Invoke(JSContext * 0x026ba210, unsigned int 1, unsigned int 0) line 781 + 23 
bytes
js_Interpret(JSContext * 0x026ba210, long * 0x0012df24) line 2674 + 15 bytes
js_Invoke(JSContext * 0x026ba210, unsigned int 1, unsigned int 2) line 798 + 13 
bytes
js_InternalInvoke(JSContext * 0x026ba210, JSObject * 0x00e19f38, long 67127728, 
unsigned int 0, unsigned int 1, long * 0x0012e0bc, long * 0x0012e04c) line 870 + 
20 bytes
JS_CallFunctionValue(JSContext * 0x026ba210, JSObject * 0x00e19f38, long 
67127728, unsigned int 1, long * 0x0012e0bc, long * 0x0012e04c) line 3299 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x026ba3c0, void * 0x00e19f38, 
void * 0x040049b0, unsigned int 1, void * 0x0012e0bc, int * 0x0012e0b8, int 0) 
line 940 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x04f17384) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x045273b0, 
nsIDOMEvent * 0x04f17384, nsIDOMEventTarget * 0x037fffa8, unsigned int 8, 
unsigned int 7) line 916 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x026bab00, nsEvent * 
0x0012e8a8, nsIDOMEvent * * 0x0012e838, nsIDOMEventTarget * 0x037fffa8, unsigned 
int 7, nsEventStatus * 0x0012e8cc) line 1467 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x037fffa0, nsIPresContext * 
0x026bab00, nsEvent * 0x0012e8a8, nsIDOMEvent * * 0x0012e838, unsigned int 1, 
nsEventStatus * 0x0012e8cc) line 3634
nsXULTreeElement::FireOnSelectHandler(nsXULTreeElement * const 0x048cf19c) line 
455
nsXULTreeElement::SetSuppressOnSelect(nsXULTreeElement * const 0x048cf198, int 
0) line 152
nsXULTreeElement::SelectItem(nsXULTreeElement * const 0x048cf198, 
nsIDOMXULElement * 0x04784374) line 187
XULTreeElementSelectItem(JSContext * 0x026ba210, JSObject * 0x00e19f38, unsigned 
int 1, long * 0x04087d54, long * 0x0012eb80) line 272 + 24 bytes
js_Invoke(JSContext * 0x026ba210, unsigned int 1, unsigned int 0) line 781 + 23 
bytes
js_Interpret(JSContext * 0x026ba210, long * 0x0012f9f0) line 2674 + 15 bytes
js_Execute(JSContext * 0x026ba210, JSObject * 0x00d3b760, JSScript * 0x04e91e40, 
JSStackFrame * 0x00000000, unsigned int 0, long * 0x0012f9f0) line 960 + 13 
bytes
JS_EvaluateUCScriptForPrincipals(JSContext * 0x026ba210, JSObject * 0x00d3b760, 
JSPrincipals * 0x025d9044, const unsigned short * 0x0012faac, unsigned int 33, 
const char * 0x04eec2e0, unsigned int 279, long * 0x0012f9f0) line 3252 + 25 
bytes
nsJSContext::EvaluateString(nsJSContext * const 0x026ba3c0, const 
basic_nsAReadableString<unsigned short> & {...}, void * 0x00d3b760, nsIPrincipal 
* 0x025d9040, const char * 0x04eec2e0, unsigned int 279, const char * 
0x003155f8, basic_nsAWritableString<unsigned short> & {...}, int * 0x0012fa90) 
line 609 + 68 bytes
GlobalWindowImpl::RunTimeout(nsTimeoutImpl * 0x04f2efa0) line 3272 + 97 bytes
nsGlobalWindow_RunTimeout(nsITimer * 0x04f2ee90, void * 0x04f2efa0) line 3550 + 
15 bytes
nsTimer::Fire() line 194 + 17 bytes
nsTimerManager::FireNextReadyTimer(nsTimerManager * const 0x025dbb70, unsigned 
int 0) line 117
nsAppShell::Run(nsAppShell * const 0x00b0d110) line 118
nsAppShellService::Run(nsAppShellService * const 0x00b0ddf0) line 408
main1(int 4, char * * 0x00a34030, nsISupports * 0x00000000) line 1004 + 32 bytes
main(int 4, char * * 0x00a34030) line 1298 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()
(Assignee)

Comment 1

17 years ago
I'll look into this.
Assignee: naving → bienvenu
(Assignee)

Comment 2

17 years ago
*** Bug 74022 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 72889
(Assignee)

Comment 3

17 years ago
changing summary - patch coming up. Can I get an r/sr=?
Summary: Mail crashes on load, when message size is of the order of ~500kb → assertions when loading a folder with only one thread.
(Assignee)

Comment 4

17 years ago
Created attachment 29177 [details] [diff] [review]
proposed fix
(Reporter)

Comment 5

17 years ago
r=naving
(Assignee)

Comment 7

17 years ago
fix checked in - might let navin or jgmyers verify since assertions only show up
in debug builds.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Stephen, do you use the debug build?
I can spin a debug build.  Accepting as QA contact for this.
QA Contact: esther → stephend
I got an M_CONTENT_VIEWER and a docshell assertion, so I don't think I'm seeing 
the same thing.  Marking verified reopen if I'm incorrect, please.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.