Last Comment Bug 739915 - Remove Firefox 2 UI migration code
: Remove Firefox 2 UI migration code
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 14
Assigned To: Dão Gottwald [:dao]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 02:02 PDT by Dão Gottwald [:dao]
Modified: 2012-03-29 08:50 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.12 KB, patch)
2012-03-28 02:02 PDT, Dão Gottwald [:dao]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-03-28 02:02:17 PDT
Created attachment 610039 [details] [diff] [review]
patch

Time to let go...
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-28 10:40:40 PDT
It looks like the negative effects to someone not hitting this code are that their back/forward buttons will disappear (but still be recoverable by customizing). That's seems fine given how likely there are to be any users hitting this path, I guess, but it also doesn't seem like such a huge burden to maintain given that we're doing other similar migration anyways.

Ideally I'd like to move this migrateUI code to it's own module, it doesn't really need to live in nsBrowserGlue.

I guess this also highlights the fact that it would be handy for future migration code auditing if we made sure to clearly label new migration paths with a comment indicating which Firefox version they're relevant to (the other blocks don't mention versions - easy enough to do the blame dance, but comments would be quicker).
Comment 2 Dão Gottwald [:dao] 2012-03-28 10:56:19 PDT
This isn't covered by tests and nobody's actively making sure it keeps working as expected -- which is why this doesn't seem like a burden. This would be ok if only profiles upgrading from Firefox 2 hit this code. However, it runs in every new profile. So I really do think we should progressively get rid of the ancient migration paths.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-28 11:04:47 PDT
Good point re: new profiles. To be clear, I wasn't really objecting to the removal, I was mostly just thinking out loud :)
Comment 5 Marco Bonardo [::mak] 2012-03-29 08:50:10 PDT
https://hg.mozilla.org/mozilla-central/rev/97377dc12755

Note You need to log in before you can comment on or make changes to this bug.