Last Comment Bug 739919 - browser/components/build fails to link on mingw
: browser/components/build fails to link on mingw
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: Firefox 14
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 02:42 PDT by Jacek Caban
Modified: 2012-03-31 19:40 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (1.33 KB, patch)
2012-03-28 02:42 PDT, Jacek Caban
jmathies: review+
Details | Diff | Review

Description Jacek Caban 2012-03-28 02:42:54 PDT
Created attachment 610051 [details] [diff] [review]
fix v1.0

That's because GCC doesn't support #pragma comment(lib, ...) construct added in bug 491947. The fix is to use OS_LIBS the way all other imports do.
Comment 1 Jacek Caban 2012-03-30 04:39:35 PDT
Thanks for the review:

https://hg.mozilla.org/integration/mozilla-inbound/rev/6a45337b5ed6
Comment 2 Ed Morley [:emorley] 2012-03-31 19:40:53 PDT
https://hg.mozilla.org/mozilla-central/rev/6a45337b5ed6

Note You need to log in before you can comment on or make changes to this bug.