Last Comment Bug 740072 - Perspective origin checks the parent frame instead of style parent
: Perspective origin checks the parent frame instead of style parent
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Matt Woodrow (:mattwoodrow) (PTO until 27 June)
:
Mentors:
Depends on:
Blocks: 505115
  Show dependency treegraph
 
Reported: 2012-03-28 11:34 PDT by Matt Woodrow (:mattwoodrow) (PTO until 27 June)
Modified: 2012-04-27 06:52 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use the style parent for perspective-origin (4.56 KB, patch)
2012-03-28 11:34 PDT, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
roc: review+
Details | Diff | Review

Description Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2012-03-28 11:34:53 PDT
Created attachment 610217 [details] [diff] [review]
Use the style parent for perspective-origin

We're looking at the wrong style context when looking for perpsective-origin, and thus missing it sometimes. Since this leaves us with the default (50% 50%), our drawing becomes dependent on the size of the parent frame, this test checks this.
Comment 1 :Aryeh Gregor (away until August 15) 2012-04-01 06:09:08 PDT
Comment on attachment 610217 [details] [diff] [review]
Use the style parent for perspective-origin

>+.parentWithPerspective {
>+  -moz-perspective: 100px;
>+  -moz-perspective-origin: 150px 150px;
>+  -webkit-perspective: 100px;
>+  -webkit-perspective-origin: 150px 150px;
>+  /* Changing width/height to 500px should not change the rendering. */
>+  height:100%;
>+}
>...
>+.parentWithPerspective {
>+  -moz-perspective: 100px;
>+  -moz-perspective-origin: 150px 150px;
>+  -webkit-perspective: 100px;
>+  -webkit-perspective-origin: 250px 150px;
>+  /* Changing width/height to 500px should not change the rendering. */
>+  height:500px;
>+}

Is it deliberate that you changed -webkit-perspective-origin from 150px 150px to 250px 150px here?  (Or that you included -webkit- properties at all?)
Comment 2 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2012-04-26 17:27:30 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1751cbffa708

Note You need to log in before you can comment on or make changes to this bug.