Last Comment Bug 740244 - We should not compile glx test when EGL provider enabled
: We should not compile glx test when EGL provider enabled
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: ARM Linux
: -- normal (vote)
: mozilla14
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 20:36 PDT by Oleg Romashin (:romaxa)
Modified: 2012-04-12 10:30 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't build glx test on non GLX platform (2.01 KB, patch)
2012-03-28 20:36 PDT, Oleg Romashin (:romaxa)
joe: review+
Details | Diff | Review
Don't build glx test on non GLX platform (3.30 KB, patch)
2012-04-10 13:15 PDT, Oleg Romashin (:romaxa)
jacob.benoit.1: review+
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2012-03-28 20:36:25 PDT
Created attachment 610404 [details] [diff] [review]
Don't build glx test on non GLX platform

After GLProvider define and cleanup I guess we can define glx test compilation more nicely, only when GLX provider enabled
Comment 1 Joe Drew (not getting mail) 2012-03-29 10:03:28 PDT
Comment on attachment 610404 [details] [diff] [review]
Don't build glx test on non GLX platform

Review of attachment 610404 [details] [diff] [review]:
-----------------------------------------------------------------

lovely
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-03-29 14:32:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c149ce94c49
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-03-29 15:23:41 PDT
http://mozillamemes.tumblr.com/post/19498220636/try-server-takes-the-beatings-so-mozilla-inbound

Backed out due to WebGL mochitest orange.
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c149ce94c49

Also, please add the appropriate information to your ~/.hgrc file per the link below to make checkins easier. Thanks!
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-03-29 15:24:17 PDT
47571 INFO TEST-START | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html
++DOMWINDOW == 306 (0x5acf488) [serial = 1084] [outer = 0x48d5ca0]
++DOCSHELL 0x9bd69b0 == 7 [id = 230]
++DOMWINDOW == 307 (0x7048b88) [serial = 1085] [outer = (nil)]
WARNING: Subdocument container has no frame: file /builds/slave/m-in-lnx64-dbg/build/layout/base/nsDocumentViewer.cpp, line 2442
++DOMWINDOW == 308 (0x70498f8) [serial = 1086] [outer = 0x7048b10]
JavaScript warning: http://mochi.test:8888/tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html, line 382: WebGL: Can't get a usable WebGL context
JavaScript warning: http://mochi.test:8888/tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html, line 382: WebGL: Can't get a usable WebGL context
47572 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Can't create a WebGL context
47573 INFO TEST-END | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | finished in 196ms
Comment 5 Benoit Jacob [:bjacob] (mostly away) 2012-04-10 13:01:52 PDT
This orange means that the feature test for GLX didn't work and glxtest got disabled also on GLX, causing WebGL to be blacklisted.
Comment 6 Oleg Romashin (:romaxa) 2012-04-10 13:13:10 PDT
Ok, I see where is the problem
Comment 7 Oleg Romashin (:romaxa) 2012-04-10 13:15:40 PDT
Created attachment 613732 [details] [diff] [review]
Don't build glx test on non GLX platform

Ok, this version should be better, will check it on try first
Comment 8 Oleg Romashin (:romaxa) 2012-04-11 11:05:07 PDT
Try build for latest version
https://tbpl.mozilla.org/?tree=Try&rev=a413d468523a
Comment 9 Benoit Jacob [:bjacob] (mostly away) 2012-04-11 11:20:57 PDT
Side note: when you will want to turn on driver blacklisting on Meego, go in widget/xpwidget/GfxInfoX11.cpp, search for #ifdef MOZ_PLATFORM_MAEMO, replace that by a check for USE_GLX_TEST.
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-04-11 15:02:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b5c840841c1
Comment 11 Richard Newman [:rnewman] 2012-04-11 15:38:04 PDT
Backed out whole merge for bustage per Yoric (Bug 743574):

https://hg.mozilla.org/integration/mozilla-inbound/rev/12e42fb8e321
Comment 12 Richard Newman [:rnewman] 2012-04-11 17:54:58 PDT
Disregard that; PEBKAC. Did not get backed out. I misread TBPL.
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-12 10:30:25 PDT
https://hg.mozilla.org/mozilla-central/rev/2b5c840841c1

Note You need to log in before you can comment on or make changes to this bug.