Closed Bug 740321 Opened 11 years ago Closed 6 years ago

Address bar unresponsive when previously focusing a pdf opened with Acrobat

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: virgil.dicu, Unassigned)

Details

(Whiteboard: [12b3])

Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0

1. Install Adobe Reader for Linux (version 9.4)
2. Start any Firefox version.
3. Open a pdf file. (e.g. samplepdf.com/sample.pdf)
4. Focus the pdf.
5. Select the address bar.
6. Move the pointer back to the pdf page (without selecting it).
7. Attempt to use the keyboard/enter any character.

While the pointer is moved towards the pdf are, no input is recognized in the address bar. Also occurs with the search bar.

I can also reproduce this with Firefox 4, so this hasn't regressed recently. Opera works fine for me under the same system and same acrobat version.
Java pages work fine with the above steps in Firefox.
Summary: Adress bar unresponsive when previously focusing a pdf opened with Acrobat → Address bar unresponsive when previously focusing a pdf opened with Acrobat
Whiteboard: [12b3]
Virgil: Did you test this on any other platforms?
Virgil: Where did you get Adobe Reader from? Is it the Adobe shipped version or is it from the Linux repository?
Marcia, yes, sorry, I couldn't reproduce the issue on Windows XP. Should have maked it clear in the description.

Anthony: it's the Adobe shipped version. I was directed to this version while searching for it on Adobe's site.
Does Nightly fair any better?
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120329 Firefox/14.0a1

Nightly exhibits the same issue as reported in comment 0.
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.