Yandex Toolbar crashes Firefox

RESOLVED DUPLICATE of bug 700493

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 700493
6 years ago
6 years ago

People

(Reporter: alindeac, Unassigned)

Tracking

12 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

Firefox crashes when installing Yandex Toolbar. 

Reproducible: sometimes 

Steps to reproduce:
1. Navigate to http://bar.yandex.ru/en/
2. Download Yandex Bar for Firefox and restart.
3. At start-up uncheck all the boxes from the Yandex.Bar window and click on the Cancel button.
4. When the Yandex.Bar disabled dialog pops up click on the Ok button.
5. If Firefox didn't crashed go to the Add-on Manager -> enable Yandex Toolbar -> restart Firefox and repeat step 4.

Expected results:
Firefox starts.

Actual results:
Firefox crashes.
https://crash-stats.mozilla.com/report/index/bp-e7b48ef0-884e-4614-b9ca-93bfd2120329
https://crash-stats.mozilla.com/report/index/bp-0bbaba77-0b6e-429e-837d-4dd492120329
https://crash-stats.mozilla.com/report/index/bp-f5c76452-aa2d-4b46-9ef3-529e92120329
https://crash-stats.mozilla.com/report/index/bp-fb5d05fd-fc05-41d0-a3f7-81b412120329

Note: Reproducible on Firefox 12 beta 3.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 700493
Simona, can you please add (to this bug, I don't want to pollute bug 700493) whether you can reproduce with a fresh new profile?  Thanks.
(In reply to Honza Bambas (:mayhemer) from comment #2)
> Simona, can you please add (to this bug, I don't want to pollute bug 700493)
> whether you can reproduce with a fresh new profile?  Thanks.

Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

Issue is also reproducible with a clean profile.
https://crash-stats.mozilla.com/report/index/a0e2cbc7-a1c4-4be3-bdb8-4a2e42120418
Simona, please test a try build at:

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/honzab.moz@firemni.cz-709574eae66c/

The link will be active in some 2 or 3 hours (it currently builds).  It is a mozilla-central build including patch https://bugzilla.mozilla.org/attachment.cgi?id=616533&action=diff that should fix this crash.

Thanks for your great help so far!
(In reply to Honza Bambas (:mayhemer) from comment #4)
> Simona, please test a try build at:
> 
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/honzab.
> moz@firemni.cz-709574eae66c/
> 
> The link will be active in some 2 or 3 hours (it currently builds).  It is a
> mozilla-central build including patch
> https://bugzilla.mozilla.org/attachment.cgi?id=616533&action=diff that
> should fix this crash.
> 
> Thanks for your great help so far!

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120419 Firefox/14.0a1

With the provided try build - Firefox does not crash. Tested on Windows 7.
You need to log in before you can comment on or make changes to this bug.