Last Comment Bug 740375 - get rid nsIAccessible innerHTML method
: get rid nsIAccessible innerHTML method
Status: RESOLVED FIXED
[good first bug][mentor=eitan@monoton...
: addon-compat, dev-doc-needed
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Mark Capella [:capella]
:
Mentors:
Depends on:
Blocks: dexpcoma11y
  Show dependency treegraph
 
Reported: 2012-03-29 08:26 PDT by alexander :surkov
Modified: 2012-05-11 01:00 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (4.61 KB, patch)
2012-03-30 13:13 PDT, Mark Capella [:capella]
tbsaunde+mozbugs: review+
Details | Diff | Review

Description alexander :surkov 2012-03-29 08:26:22 PDT
1) remove innerHTML method from nsIAccessible interface (http://mxr.mozilla.org/mozilla-central/source/accessible/public/nsIAccessible.idl?force=1#111)
2) bump uuid of nsIAccessible interface
3) remove GetInnerHTML implementation from nsAccessible and nsApplicationAccessible (see accessible/src/base folder)
4) move the logic of nsAccessible::GetInnerHTML to nsAccessNodeWrap::get_innerHTML (see accessible/src/msaa) where it's used
Comment 1 Trevor Saunders (:tbsaunde) 2012-03-29 19:12:48 PDT
(In reply to alexander :surkov from comment #0)
> 1) remove innerHTML method from nsIAccessible interface
> (http://mxr.mozilla.org/mozilla-central/source/accessible/public/
> nsIAccessible.idl?force=1#111)

any particular reason you want to remove this method?  it doesn't completely make sense or really have a clear purpose,but it doesn't seem its really hurting any one either.

> 4) move the logic of nsAccessible::GetInnerHTML to
> nsAccessNodeWrap::get_innerHTML (see accessible/src/msaa) where it's used

it looks like it already uses its own logic which is the same.  Although perhaps it should use something other than qi and nsIDOMHTMLElement
Comment 2 alexander :surkov 2012-03-29 19:32:54 PDT
(In reply to Trevor Saunders (:tbsaunde) from comment #1)
> (In reply to alexander :surkov from comment #0)
> > 1) remove innerHTML method from nsIAccessible interface
> > (http://mxr.mozilla.org/mozilla-central/source/accessible/public/
> > nsIAccessible.idl?force=1#111)
> 
> any particular reason you want to remove this method?  it doesn't completely
> make sense or really have a clear purpose,but it doesn't seem its really
> hurting any one either.

this method is just a shortcut around HTML element innerHTML, doesn't make sense to dupe it on accessibility layer

> > 4) move the logic of nsAccessible::GetInnerHTML to
> > nsAccessNodeWrap::get_innerHTML (see accessible/src/msaa) where it's used
> 
> it looks like it already uses its own logic which is the same.  Although
> perhaps it should use something other than qi and nsIDOMHTMLElement

you're right, I missed that (it was late night for me :) ) So no 4) item.
Comment 3 Mark Capella [:capella] 2012-03-30 13:13:56 PDT
Created attachment 610983 [details] [diff] [review]
Patch (v1)

Looks fairly simple, built out ok, passed all mochitest-a11y tests ...
Comment 4 Trevor Saunders (:tbsaunde) 2012-04-01 00:52:38 PDT
landed https://hg.mozilla.org/integration/mozilla-inbound/rev/57bd8957e1b4
Comment 5 Matt Brubeck (:mbrubeck) 2012-04-02 11:03:56 PDT
https://hg.mozilla.org/mozilla-central/rev/57bd8957e1b4

Note You need to log in before you can comment on or make changes to this bug.