ALIASEDVAR Patch: Assertion failure: [infer failure] Missing type pushed 0: float, at jsinfer.cpp:352

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: decoder, Assigned: luke)

Tracking

(Blocks: 1 bug, {assertion, testcase})

unspecified
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The following test asserts on mozilla-central revision 7ed31daf07bd with patch from bug 740259 (options -m -n -a):


function g1() {}
function g2() 
function Int8Array () {}   
function f1(other) {
    eval("gc(); h = g1");
    for(var i=0; i<20; i++) {
        i = i.name;
    }
}
f1(g2);
(Assignee)

Comment 1

5 years ago
I'll add the testcase to the batch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 740445
Fixed by new patch in bug 740445 -> FIXED
Resolution: DUPLICATE → FIXED
Or in bug 740259.
(Reporter)

Comment 4

4 years ago
A testcase for this bug was automatically identified at js/src/jit-test/tests/basic/testBug740442.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.