Last Comment Bug 740469 - JSNative->JSFunction fixup should happen in DefinePropertyById, not DefineProperty
: JSNative->JSFunction fixup should happen in DefinePropertyById, not DefinePro...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Bobby Holley (PTO through June 13)
:
Mentors:
Depends on:
Blocks: 740069
  Show dependency treegraph
 
Reported: 2012-03-29 10:35 PDT by Bobby Holley (PTO through June 13)
Modified: 2012-03-30 13:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch. v1 (5.39 KB, patch)
2012-03-29 10:56 PDT, Bobby Holley (PTO through June 13)
luke: review+
Details | Diff | Review

Description Bobby Holley (PTO through June 13) 2012-03-29 10:35:19 PDT
We need this stuff in the dom bindings, but it seems silly to convert our JSID to a char* just to take advantage of this. Patch coming right up.
Comment 1 Bobby Holley (PTO through June 13) 2012-03-29 10:56:52 PDT
Created attachment 610601 [details] [diff] [review]
patch. v1

Attaching a patch. Flagging luke for review.
Comment 2 Bobby Holley (PTO through June 13) 2012-03-29 11:02:08 PDT
Pushed this to try: https://tbpl.mozilla.org/?tree=Try&rev=7a2dbe5f12e4
Comment 3 Bobby Holley (PTO through June 13) 2012-03-29 13:37:42 PDT
Looks like the try oranges were the result of the patch underneath, which was backed out on inbound.

Pushed to m-i: http://hg.mozilla.org/integration/mozilla-inbound/rev/5ed5a3e3acc4
Comment 4 Ed Morley [:emorley] 2012-03-30 13:02:22 PDT
https://hg.mozilla.org/mozilla-central/rev/5ed5a3e3acc4

Note You need to log in before you can comment on or make changes to this bug.