Last Comment Bug 740482 - Create nice breakpoint icons for the SourceEditor in the Debugger
: Create nice breakpoint icons for the SourceEditor in the Debugger
Status: RESOLVED FIXED
[sourceeditor][fixed-in-fx-team]
: uiwanted
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: Firefox 15
Assigned To: Rob Campbell [:rc] (:robcee)
:
Mentors:
Depends on:
Blocks: 753301
  Show dependency treegraph
 
Reported: 2012-03-29 10:52 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2012-06-01 05:51 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Breakpoint Icon Mockup (30.17 KB, image/png)
2012-04-03 12:44 PDT, Stephen Horlander [:shorlander]
no flags Details
Treetwisty as the location indicator (730 bytes, patch)
2012-05-25 02:46 PDT, Panos Astithas [:past]
no flags Details | Diff | Splinter Review
Current icons (19.57 KB, image/png)
2012-05-29 05:39 PDT, Panos Astithas [:past]
no flags Details
The Treetwisty icon (20.29 KB, image/png)
2012-05-29 05:41 PDT, Panos Astithas [:past]
no flags Details
breakpoint-icons (5.03 KB, patch)
2012-05-30 09:30 PDT, Rob Campbell [:rc] (:robcee)
dcamp: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2012-03-29 10:52:34 PDT
The SourceEditor should have nicer icons for showing breakpoints.
Comment 1 Rob Campbell [:rc] (:robcee) 2012-03-29 10:53:58 PDT
Also need a "current line arrow" icon.
Comment 2 Rob Campbell [:rc] (:robcee) 2012-03-29 12:18:42 PDT
cc'ing shorlander.

I'll add a screencap with the current buttons for examination.
Comment 3 Stephen Horlander [:shorlander] 2012-04-03 12:44:54 PDT
Created attachment 611937 [details]
Breakpoint Icon Mockup
Comment 4 Rob Campbell [:rc] (:robcee) 2012-04-04 09:20:21 PDT
darn, I never did add that screencap. Do you need one?

Those icons look pretty sweet. Also, can I have that color theme for the editor? :)
Comment 5 Rob Campbell [:rc] (:robcee) 2012-04-04 09:21:41 PDT
mihai: does this look feasible or are we stuck using n x n images in the gutter? This looks like it'd be better implemented in CSS than using an image.
Comment 6 Paul Rouget [:paul] 2012-04-04 09:27:30 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #4)
> darn, I never did add that screencap. Do you need one?
> 
> Also, can I have that color theme for the editor?

This should happen here: bug 715472 (not sure if you meant to implement the theme here)
Comment 7 Mihai Sucan [:msucan] 2012-04-04 09:56:47 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #5)
> mihai: does this look feasible or are we stuck using n x n images in the
> gutter? This looks like it'd be better implemented in CSS than using an
> image.

The AnnotationRuler used for the debugger icons does not "communicate" in any way with the LineNumberRuler, unfortunately. This code comes from upstream.

From CSS we can only change the icons and a bit of styling for the AnnotationRuler.

If we want the design as proposed by shorlander (I want it!) we need to write a bit of JS code: write our own LineNumberRuler that allows us to do what we need. I doubt this is code we need to go upstream for - we can handle our editor UI as we see fit.

Thoughts?
Comment 8 Rob Campbell [:rc] (:robcee) 2012-04-19 11:37:55 PDT
prioritizing as P2.
Comment 9 Panos Astithas [:past] 2012-05-25 02:46:04 PDT
Created attachment 627149 [details] [diff] [review]
Treetwisty as the location indicator

If we don't get new icons in time, how about using the treetwisty arrow as the current line indicator?
Comment 10 Rob Campbell [:rc] (:robcee) 2012-05-29 04:43:16 PDT
what does that look like? I think it'll be offset won't it?
Comment 11 Panos Astithas [:past] 2012-05-29 05:39:42 PDT
Created attachment 627924 [details]
Current icons
Comment 12 Panos Astithas [:past] 2012-05-29 05:41:23 PDT
Created attachment 627925 [details]
The Treetwisty icon

(In reply to Rob Campbell [:rc] (:robcee) from comment #10)
> what does that look like? I think it'll be offset won't it?

Yes, I think it's a little more offset than the current icon. At least with the dumb patch that I attached.
Comment 13 Rob Campbell [:rc] (:robcee) 2012-05-30 09:30:53 PDT
Created attachment 628358 [details] [diff] [review]
breakpoint-icons

simple patch to replace the current icons with shorlander's improved ones.

These still suffer from some funny offsets.
Comment 14 Rob Campbell [:rc] (:robcee) 2012-05-31 16:24:23 PDT
https://hg.mozilla.org/integration/fx-team/rev/1a1529306022
Comment 15 Rob Campbell [:rc] (:robcee) 2012-06-01 05:51:29 PDT
https://hg.mozilla.org/mozilla-central/rev/1a1529306022

Note You need to log in before you can comment on or make changes to this bug.