Last Comment Bug 740721 - pinch and zoom don't work on the Windows with touch input displays
: pinch and zoom don't work on the Windows with touch input displays
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Windows 8
: -- normal (vote)
: Firefox 15
Assigned To: Jim Mathies [:jimm]
:
Mentors:
: 750647 (view as bug list)
Depends on:
Blocks: 613909
  Show dependency treegraph
 
Reported: 2012-03-30 00:24 PDT by Jim Mathies [:jimm]
Modified: 2012-06-01 14:57 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
fix (1.20 KB, patch)
2012-05-29 12:32 PDT, Jim Mathies [:jimm]
no flags Details | Diff | Review
patch (1.29 KB, patch)
2012-05-30 02:06 PDT, Jim Mathies [:jimm]
dao+bmo: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta-
Details | Diff | Review

Description Jim Mathies [:jimm] 2012-03-30 00:24:19 PDT
This could be in widget or something higher up. We added touch input support back when win7 was released, this seems to have broken.

STR:

1) open a web page on the desktop
2) pinch or zoom the page

result: nothing happen.
Comment 1 Jim Mathies [:jimm] 2012-05-25 12:06:42 PDT
*** Bug 750647 has been marked as a duplicate of this bug. ***
Comment 2 Jim Mathies [:jimm] 2012-05-29 12:32:39 PDT
Created attachment 628060 [details] [diff] [review]
fix
Comment 3 Jim Mathies [:jimm] 2012-05-29 12:33:37 PDT
Comment on attachment 628060 [details] [diff] [review]
fix

Reverting changes in bug 613909 for Windows.
Comment 4 Dão Gottwald [:dao] 2012-05-29 16:20:37 PDT
Comment on attachment 628060 [details] [diff] [review]
fix

Please use ifdef instead of ifndef, swapping these two sections. Can you also add a comment explaining why this varies across OSes?
Comment 5 Jim Mathies [:jimm] 2012-05-30 02:06:52 PDT
Created attachment 628275 [details] [diff] [review]
patch

Updated.
Comment 7 Ed Morley [:emorley] 2012-05-31 06:18:14 PDT
https://hg.mozilla.org/mozilla-central/rev/b9fd71b7bde2
Comment 8 Jim Mathies [:jimm] 2012-05-31 06:51:02 PDT
Comment on attachment 628275 [details] [diff] [review]
patch

This change enables functionality we mistakenly disabled about a year ago for windows touch input displays. Unfortunately once disabled, it stays disabled unless the user manually edits config settings.

Microsoft will have a fresh preview release of win8 due out in the next few weeks, so I would like to get this out to beta in the hope that this functionality will be available for fresh installs on the new os rev.
Comment 9 Alex Keybl [:akeybl] 2012-06-01 14:20:38 PDT
Comment on attachment 628275 [details] [diff] [review]
patch

[Triage Comment]
This is too late for FF13, but appears to be low risk enough to approve for Aurora 14.

Note You need to log in before you can comment on or make changes to this bug.