Edit to about:config to disable per-site remembering download directory doesn't work

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Cloudchaser1@comcast.net, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-05-10])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 610824 [details]
Capture.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Bug ID #702748 is listed as resolved/fixed, but it's not.  To quote Mr. Lankow, "Lots of users are complaining about this feature, so we should have a pref to disable it"

I created a new Boolean pref with the name browser.download.lastdir.savePerSite and set the value to false.  I tried cleared my recent history with no tabs open except for a blank New Tab. In the dropdown, I selected Everything and in the checkboxes, I selected Browsing & Download History, Form & Search History, Cookies and Cache.

I was asked for and provided a screenshot of the about:config page that shows the browser.download.lastdir.savePerSite pref. I was told "That looks good to me, so the pref should be working. Any luck if you delete (or rename/move) the permissions.sqlite file in the Firefox Profile Folder?"

I Tried that with Firefox closed preceded by Clear Recent History with Everything and Site Preferences selected before closing Firefox to be sure. Unfortunately, that didn't do the trick.

There needs to be a checkbox in options/general/downloads to "disable per-site remembering of download directory"


Actual results:

None of the things I was advised to do had any effect, per-site remembering of download directory was not disabled.


Expected results:

Per-site remembering of download directory should have been disabled.
(Reporter)

Comment 1

6 years ago
I should add that I made every attempt possible to find a way to resolve this in the user hep forum before posting here.  My last try there was answered by someone who said I should post here after which the topic was locked.

Comment 2

6 years ago
I'm 99% sure the problem is that you created the preference
  browser.download.lastdir.savePerSite,
as opposed to
  browser.download.lastDir.savePerSite

(lowercase "d" instead of capital "D" in lastDir)

Please post back so that we can close this bug or try other troubleshooting.
Whiteboard: [closeme 2012-05-10]
(Reporter)

Comment 3

6 years ago
That apparently did the trick.  Much thanx for your help!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.