Mozilla displays pages which required authentication (after reload) from cache

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Mirek Hankus, Assigned: gordon)

Tracking

({privacy})

Trunk
x86
All
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.8.1)
BuildID:    2001032804

Mozilla displays pages which required authentication after you restart it.
Problem is that you can open page, enter auth info, look at this page close all
the mozilla windows, someone else is comming opens mozilla and checks what you
where loooking on 

Reproducible: Always
Steps to Reproduce:
1. Start mozilla 
2. Open above URL 
3. login as user pass with password pwd
4. exit mozilla
5. start mozilla
6. open URL 
7. Page is displayed without authorization
8. Pressing reload makes mozilla ask you for username and password


Actual Results:  Page is displayed without asking for authentication

Expected Results:  Mozilla should ask for auth info

Comment 1

18 years ago
Reporter the cache in that nightly was a little to aggressive. Try again with
one of the latest nightlies? Ie todays..and see if that fixes the problem. My
bet is that it will.

Comment 2

17 years ago
*** Bug 73496 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

17 years ago
In my case build 2001042220 works fine. So WORKSFORME would be a good choice. 


dup bug is on Linux
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: correctness, privacy
OS: Windows ME → All

Comment 5

17 years ago
Marking WORKSFORME based on reporters comments.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.