B2G RIL: permanent connecting for inserted SIM card

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: surkov, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking-kilimanjaro:-, blocking-basecamp:-)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
presumably different from bug 731786 since my SIM card doesn't have defined PIN code. What kind of info should I provide to help you to figure out where the problem is?
(In reply to alexander :surkov from comment #0)
> presumably different from bug 731786 since my SIM card doesn't have defined
> PIN code. What kind of info should I provide to help you to figure out where
> the problem is?

Which phone, which build, which SIM card provider, etc.
(Reporter)

Comment 2

7 years ago
Phone: Samsung Galaxy S II GT-I9100
Build: I believe 2012-03-30 (yesterday I synced B2G and gaia and flushed them). How can I check?
SIM card provider: BWC (http://www.bwc.ru/). I don't think it requires any special support (at least something different from other providers in Russia) but I'd happy to find out the info you need.

If there's a way to log what happens and send a log to you then I'd happy to do that as well.
(In reply to alexander :surkov from comment #2)
> Phone: Samsung Galaxy S II GT-I9100
> Build: I believe 2012-03-30 (yesterday I synced B2G and gaia and flushed
> them). How can I check?
> SIM card provider: BWC (http://www.bwc.ru/). I don't think it requires any
> special support (at least something different from other providers in
> Russia) but I'd happy to find out the info you need.

You're 100% sure the SIM card is inserted, yes? Otherwise you might be seeing bug 740231.

Also, did the SIM card work in the SGS2 before you flashed B2G on it?

> If there's a way to log what happens and send a log to you then I'd happy to
> do that as well.

Yes! Please turn DEBUG = true in dom/system/gonk/ril_worker.js and RadioInterfaceLayer.js, `make install-gecko`, and reboot the phone. Then attach the output of `adb logcat`. Thanks!
(Reporter)

Comment 4

7 years ago
Created attachment 611737 [details]
log1
John, can you see if you can reproduce this?
blocking-basecamp: --- → +
Keywords: qawanted
blocking-kilimanjaro: --- → +
Minusing because SGS2. Re-open if reproduce-able on Otoro/Akami.
blocking-basecamp: + → -
blocking-kilimanjaro: + → -
Resolving for now, please reopen if it occurs on said devices.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
:surkov, unforunately I can't read russian and google translate doesn't seem to work well on that webpage.  Is there any way you might be able point us to a web page to get a SIM from them?  I am uncertain also if we would even get a signal being in the states.

Removing QAWanted from the bug as I can't reproduce this with the SIMs that I have.
Flags: needinfo?(surkov.alexander)
Keywords: qawanted
(Reporter)

Comment 9

6 years ago
(In reply to Naoki Hirata :nhirata from comment #8)
> :surkov, unforunately I can't read russian and google translate doesn't seem
> to work well on that webpage.  Is there any way you might be able point us
> to a web page to get a SIM from them?

Perhaps they don't have this option. Just in case I've sent them a letter pointing to this bug.

>  I am uncertain also if we would even
> get a signal being in the states.

roaming should work I think

> Removing QAWanted from the bug as I can't reproduce this with the SIMs that
> I have.

I don't have Firefox OS device right now so I can't test it. When I get one then I'll give it a try.
Flags: needinfo?(surkov.alexander)
You need to log in before you can comment on or make changes to this bug.