DIV Image inside table doesn't show up in the right place (not overlapping other cell)

RESOLVED FIXED in mozilla1.3beta

Status

()

Core
Layout: Tables
RESOLVED FIXED
18 years ago
16 years ago

People

(Reporter: ajbu, Assigned: dbaron)

Tracking

Trunk
mozilla1.3beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Windows 2000, build 2001032920

http://www.babywinkel.nl/Pages/Welcome.asp / http://www.babywinkel.nl

The image of the baby on this page top-right isn't positioned right.

On IE5 and NS476 the image 'overlaps' the cell under it.

Code of this cell:
<td valign="top" width="0%"><div class="toplayer"><img 
src="/Images/general/pixel.gif" width="81" height="1" alt="" border="0"><div 
class="babylayer"><a href="/Pages/Specialoffer.asp"><img 
src="/Images/general/baby.gif" width="81" height="102" alt="" 
border="0"></a></div></div></td>
(Reporter)

Comment 1

18 years ago
Created attachment 29237 [details]
Screenshot of this page in NS471, Mozilla and Mozilla composer
From the stylesheet:



.toplayer {
	position : relative;
	left : 0;
	top : 0;
}
.babylayer {
	position : absolute;
	left : 0;
	top : 0;
}

Comment 3

18 years ago
Confirming issue in the April 3rd build.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Confirming in todays W2K fresh pull. I've seen this on other pages as well, 
probably a dup. Over to block layout.
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
Can this be related to bug 98916?

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2
This is a tables bug.  The table cell sizes based on the out-of-flow content in
it, and it should not...
Assignee: attinasi → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → amar

Comment 7

16 years ago
it may be even a dupe of bug 172896
Depends on: 172896
(Assignee)

Comment 8

16 years ago
Taking.
Assignee: karnaze → dbaron
(Assignee)

Comment 9

16 years ago
Fixed by checkin of bug 172896.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.2alpha → mozilla1.3beta
(Assignee)

Comment 10

16 years ago
*** Bug 96220 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

16 years ago
*** Bug 118940 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.