All users were logged out of Bugzilla on October 13th, 2018

[jsdbg2] Debugger.prototype.addDebuggee should only accept global objects

RESOLVED DUPLICATE of bug 796073

Status

()

RESOLVED DUPLICATE of bug 796073
7 years ago
6 years ago

People

(Reporter: jimb, Unassigned)

Tracking

16 Branch
mozilla14
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Once bug 740542 is landed, Debugger.prototype.addDebuggee shouldn't act as a Debugger.Object factory, as Debugger.prototype.wrap does that job better. A lot of tests use addDebuggee this way; they'll need to be changed.
(Reporter)

Comment 1

7 years ago
Created attachment 611247 [details] [diff] [review]
Make Debugger.prototype.addDebuggee return undefined; change tests to use Debugger.prototype.wrap.
Assignee: general → jimb
Status: NEW → ASSIGNED
Attachment #611247 - Flags: review?(jorendorff)
(Reporter)

Comment 2

7 years ago
FOLLOWUP BUG IS FOLLOWED UP UPON
Flags: in-testsuite+
(Reporter)

Comment 4

7 years ago
(Apologies for an especially mind-numbing r?.)
Comment on attachment 611247 [details] [diff] [review]
Make Debugger.prototype.addDebuggee return undefined; change tests to use Debugger.prototype.wrap.

Clearing review flag since bug 741615 should precede this now.
Attachment #611247 - Flags: review?(jorendorff)
(Reporter)

Comment 6

7 years ago
With bug 741615 landed, our only general-purpose Debugger.Object factory is Debugger.Object.prototype.makeDebuggeeValue, meaning that one must have an initial Debugger.Object before one can produce others at will.

It would make sense, then, if addDebuggee continued to return a Debugger.Object. We can still tighten up its semantics by restricting it to operate only on actual global objects.
Summary: [jsdbg2] Debugger.prototype.addDebuggee should not be a wrapper factory → [jsdbg2] Debugger.prototype.addDebuggee should only accept global objects
(Reporter)

Updated

6 years ago
Assignee: jimb → general
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla14
Version: Trunk → 16 Branch
Duplicate of bug: 796073
You need to log in before you can comment on or make changes to this bug.