position: relative is ignored in a table-cell type block

RESOLVED DUPLICATE of bug 63895

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 63895
6 years ago
6 years ago

People

(Reporter: Fernando García Gómez, stripTM, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 611225 [details]
Test case

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310010446

Steps to reproduce:

I was using display: table-cell; position: relative; and inside this block another block with position: absolute; right: 0;


Actual results:

A block with "display:table-cell" and "position:relative" does not
establishes a containing block and the descendants blocks absolutely
positioned does not take the dimensions of the parent block. In example: a
"right:0;" takes the "absolutely positioned" block outside of the
"relatively positioned".

related #203225 ?


Expected results:

The descendent elements should be contained inside the parent block.
(Reporter)

Comment 1

6 years ago
Created attachment 611226 [details]
Attended result
(Reporter)

Updated

6 years ago
Attachment #611225 - Attachment mime type: text/plain → text/html

Comment 2

6 years ago
(In reply to Fernando García Gómez, stripTM from comment #0)
> related #203225 ?

Kinda. The bug that governs all containing block issues about internal table elements is bug 63859 which depends on bug 203225.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 63895
You need to log in before you can comment on or make changes to this bug.