Crash when opening the Print dialog [@ nsIDocument::GetRootElement]

RESOLVED DUPLICATE of bug 741053

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 741053
6 years ago
6 years ago

People

(Reporter: Anael Mobilia, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20120331 Firefox/14.0a1
Build ID: 20120331035305

Steps to reproduce:

Go to any website, press the Ctrl + P keys (shortcut for File -> Print)


Actual results:

Firefox just crash, no talkback, fatal crash


Expected results:

The printing pop-up should be displayed, giving me the ability to select my printer

Comment 1

6 years ago
Thanks for taking the time to report this problem!
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. Thanks!
(Reporter)

Comment 2

6 years ago
Hi Andre,

Same problem in safe mode.
I can't provide a crash report due to the unavailability of about:crashes (cf https://bugzilla.mozilla.org/show_bug.cgi?id=741186 )

The output from the console is :
(firefox-trunk:3364): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion `targets != NULL' failed
Erreur de segmentation

Comment 3

6 years ago
Can you provide a stack using steps in https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report?
(Reporter)

Comment 4

6 years ago
Created attachment 611289 [details]
debug log

Comment 5

6 years ago
There's something wrong with your system/firefox build (ref. bug 741186, bug 741189, bug 741187). Let's figure out bug 741186 first.

The debug log you attached lacks symbols, so it's not very useful.
Whiteboard: [waits on resolution of bug 741186]
(Reporter)

Comment 6

6 years ago
Trace log : https://crash-stats.mozilla.com/report/index/bp-c0c11351-9463-4974-a52a-000792120401
Whiteboard: [waits on resolution of bug 741186]

Comment 7

6 years ago
I'm 99% certain it will get fixed along with bug 741053, but keeping this open for now, since the steps to reproduce are different.
Crash Signature: [@ nsIDocument::GetRootElement]
Component: Untriaged → Disability Access APIs
Depends on: 741053
Product: Firefox → Core
QA Contact: untriaged → accessibility-apis
Summary: Print window -> fatal crash → Crash when opening the Print dialog [@ nsIDocument::GetRootElement]
Whiteboard: [retest after bug 741053 is fixed]
Version: 14 Branch → Trunk

Updated

6 years ago
Attachment #611289 - Attachment is obsolete: true
(Reporter)

Comment 8

6 years ago
Bug solved as https://bugzilla.mozilla.org/show_bug.cgi?id=741053
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [retest after bug 741053 is fixed]

Updated

6 years ago
No longer depends on: 741053
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 741053
You need to log in before you can comment on or make changes to this bug.