basic authentication popup should be built into current tab instead of taking over whole firefox window

RESOLVED DUPLICATE of bug 613785

Status

()

RESOLVED DUPLICATE of bug 613785
7 years ago
5 years ago

People

(Reporter: carl, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

When I go to multiple websites with each on their own tab and one of them has http basic authentication enabled.  When I mean http basic authentication, I mean the standard that apache uses with htpasswd and .htaccess files.


Actual results:

The username and password popup takes over the current window of firefox and all the tabs that are there not allowing me to do anything until I click cancel or put in the correct username and password.  It does not indicate to me which tab the username and password popup belongs to.


Expected results:

Whenever a website has http basic authentication enabled and requests the username and password, it should not popup and take over the whole current firefox window.  It should be limited to that tab and be similiar to the way that was used when a webpage cannot load.

This way I can still switch to other tabs and that username and password request is limited to the tab it is on.  It will also tell me which tab it is for.  Right now it does not tell me and I have to guess.

Here is how I think jquery is able to do this exact thing:

http://blog.rassemblr.com/2011/05/jquery-ajax-and-rest-http-basic-authentication-done-deal/

Comment 1

5 years ago
I can confirm this bug (feature request?).

Firefox is annoying when opening a session containing site with this form of authentication. Lots of the sites I need are still using htpasswd.

The way Chrome uses is just better, safer and more transparent.
Whiteboard: [dupeme]

Comment 2

5 years ago
After extensive search, duplicate of: 613785,
another possible duplicates: 91661 879005
Yeah, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 613785
You need to log in before you can comment on or make changes to this bug.