Last Comment Bug 741263 - Paris bindings constructors shouldn't abuse reserved identifiers.
: Paris bindings constructors shouldn't abuse reserved identifiers.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Peter Van der Beken [:peterv]
:
: Andrew Overholt [:overholt]
Mentors:
https://mxr.mozilla.org/mozilla-centr...
Depends on:
Blocks: 740069
  Show dependency treegraph
 
Reported: 2012-04-01 18:25 PDT by Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953)
Modified: 2012-05-23 05:20 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (21.61 KB, patch)
2012-04-02 07:27 PDT, Peter Van der Beken [:peterv]
no flags Details | Diff | Splinter Review
v1 (21.70 KB, patch)
2012-05-17 12:45 PDT, Peter Van der Beken [:peterv]
bzbarsky: review+
Details | Diff | Splinter Review

Description Masatoshi Kimura [:emk] (use Splinter to ask me for review, see bugzil.la/1321953) 2012-04-01 18:25:28 PDT
Identifiers beggining with _ + upercase letter are always reserved in C/C++.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-04-01 18:28:01 PDT
Hmm.  We need something that will never collide with WebIDL identifiers.  Peter, any ideas?  I guess we could make this CONSTRUCTOR all in caps?
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-01 18:30:33 PDT
_ + lowercase letter is not reserved, so we could just make these _constructor, _finalize, etc, right?
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-04-01 19:38:19 PDT
Oh, yes.  That would work.  Especially because we upcase all other WebIDL stuff.
Comment 4 Peter Van der Beken [:peterv] 2012-04-02 07:27:47 PDT
Created attachment 611449 [details] [diff] [review]
v1

constructor is a reserved operation name in WebIDL, so I think we should use Constructor for the native function.
Comment 5 Peter Van der Beken [:peterv] 2012-05-17 12:45:56 PDT
Created attachment 624846 [details] [diff] [review]
v1
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2012-05-17 21:08:40 PDT
Comment on attachment 624846 [details] [diff] [review]
v1

r=me
Comment 7 Peter Van der Beken [:peterv] 2012-05-22 14:32:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/34c1f88c3e7d
Comment 8 Ed Morley [:emorley] 2012-05-23 05:20:19 PDT
https://hg.mozilla.org/mozilla-central/rev/34c1f88c3e7d

Note You need to log in before you can comment on or make changes to this bug.