Closed Bug 741528 Opened 10 years ago Closed 7 years ago

Clicking on link results in a blank page but it renders OK by itself

Categories

(Firefox :: Untriaged, defect)

11 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox11 --- affected
firefox12 --- affected

People

(Reporter: Rob.Simpson, Unassigned)

Details

(Keywords: reproducible)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

When I click on the link in my comment on this G+ post: https://plus.google.com/u/0/111091089527727420853/posts/3vzChecR8TM (currently near the bottom), the page comes up blank in Firefox.  It works OK in other browsers and also in Firefox, if you enter the URL directly in the address bar (http://www.HTML-5.com/html-versions-and-history.html#history-of-html).

I see other issues regarding blank pages when displaying a PDF, but this isn't a PDF.


Actual results:

Firefox displays a blank page when it is visited via a link.


Expected results:

The page should be displayed the same as it is when you enter the URL in the address bar.
Another example.  I searched for "html script tag" and on the second page, clicked on the result in the attached image.  This time it doesn't seem to matter whether I click on the link or copy and paste it in the address bar, which is what worked for the first example.

I'm almost positive this site worked fine in the past, so is this a regression in Firefox 11?
I can reproduce on
http://hg.mozilla.org/releases/mozilla-beta/rev/e78e518d5269
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0 ID:20120328051619

But Ican not reproduce on Firefox13 and later



Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/164976bffd31
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1 ID:20110909025538
Fails:
http://hg.mozilla.org/mozilla-central/rev/694520af9b18
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909070728
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=164976bffd31&tochange=694520af9b18

Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9c8c4ee78c4e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1 ID:20110908125001
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d37091962789
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1 ID:20110908132155
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9c8c4ee78c4e&tochange=d37091962789

Regressed by:Bug 669410



Fixed window(m-c):
Fails:
http://hg.mozilla.org/mozilla-central/rev/e9183168a27d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120203 Firefox/13.0a1 ID:20120203082128
Works again:
http://hg.mozilla.org/mozilla-central/rev/4da18c2e4910
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120203 Firefox/13.0a1 ID:20120203084628
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e9183168a27d&tochange=4da18c2e4910

Fixed window(m-c):
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f515da8571f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120202 Firefox/13.0a1 ID:20120202204928
Works again:
http://hg.mozilla.org/integration/mozilla-inbound/rev/62b24f89b354
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120202 Firefox/13.0a1 ID:20120202233728
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f515da8571f5&tochange=62b24f89b354

Seemed to be fixed by:Bug 673470
Blocks: 669410
Status: UNCONFIRMED → NEW
Depends on: 673470
Ever confirmed: true
Keywords: regression
Component: Untriaged → Phishing Protection
QA Contact: untriaged → phishing.protection
Errors in Error console on Firefox12 as follows:

Error: not well-formed
Source code:
<div xmlns="http://www.w3.org/1999/xhtml"><iframe allowtransparency="true" frameborder="0" hspace="0" id="I2_1333566712051" marginheight="0" marginwidth="0" name="I2_1333566712051" scrolling="no" src="https://plusone.google.com/_/+1/fastbutton?url=http%3A%2F%2Fwww.html-5.com%2Fhtml-versions-and-history.html&size=tall&count=true&hl=en-US&jsh=m%3B%2F_%2Fapps-static%2F_%2Fjs%2Fgapi%2F__features__%2Frt%3Dj%2Fver%3DaYArk5u26EQ.ja.%2Fsv%3D1%2Fam%3D!Ze6NnRS0VYCICGRMrA%2Fd%3D1%2Frs%3DAItRSTOL_oPDaC0zppkILB_GwftozqPEJg#id=I2_1333566712051&parent=http%3A%2F%2Fwww.html-5.com&rpctoken=598976337&_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart" style="position:absolute;left:-10000px;top:-10000px;width:50px;margin:0px;border-style:none" tabindex="0" vspace="0" width="100%" title="+1" ></iframe></


Error: not well-formed
Source code:
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:g="http://base.google.com/ns/1.0"><body xmlns="http://www.w3.org/1999/xhtml"><section xmlns="http://www.w3.org/1999/xhtml"><div xmlns="http://www.w3.org/1999/xhtml"><section xmlns="http://www.w3.org/1999/xhtml"><article xmlns="http://www.w3.org/1999/xhtml"><table xmlns="http://www.w3.org/1999/xhtml"><tr xmlns="http://www.w3.org/1999/xhtml"><td xmlns="http://www.w3.org/1999/xhtml"><div xmlns="http://www.w3.org/1999/xhtml"><iframe allowtransparency="true" frameborder="0" hspace="0" id="I2_1333566712051" marginheight="0" marginwidth="0" name="I2_1333566712051" scrolling="no" src="https://plusone.google.com/_/+1/fastbutton?url=http%3A%2F%2Fwww.html-5.com%2Fhtml-versions-and-history.html&size=tall&count=true&hl=en-US&jsh=m%3B%2F_%2Fapps-static%2F_%2Fjs%2Fgapi%2F__features__%2Frt%3Dj%2Fver%3DaYArk5u26EQ.ja.%2Fsv%3D1%2Fam%3D!Ze6NnRS0VYCICGRMrA%2Fd%3D1%2Frs%3DAItRSTOL_oPDaC0zppkILB_GwftozqPEJg#id=I2_1333566712051&parent=http%3A%2F%2Fwww.html-5.com&rpctoken=598976337&_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart" style="position:absolute;left:-10000px;top:-10000px;width:50px;margin:0px;border-style:none" tabindex="0" vspace="0" width="100%" title="+1" ></iframe></


Error: not well-formed
Source code:
<div xmlns="http://www.w3.org/1999/xhtml"><iframe allowtransparency="true" frameborder="0" hspace="0" id="I1_1333566712014" marginheight="0" marginwidth="0" name="I1_1333566712014" scrolling="no" src="https://plusone.google.com/u/0/_/pages/badge?url=https%3A%2F%2Fplus.google.com%2F100115770145624791433&size=badge&width=300&height=69&theme=light&hl=en-US&jsh=m%3B%2F_%2Fapps-static%2F_%2Fjs%2Fgapi%2F__features__%2Frt%3Dj%2Fver%3DaYArk5u26EQ.ja.%2Fsv%3D1%2Fam%3D!Ze6NnRS0VYCICGRMrA%2Fd%3D1%2Frs%3DAItRSTOL_oPDaC0zppkILB_GwftozqPEJg#id=I1_1333566712014&parent=http%3A%2F%2Fwww.html-5.com&rpctoken=723659509&_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart" style="position:absolute;left:-10000px;top:-10000px;width:300px;margin:0px;border-style:none" tabindex="0" vspace="0" width="100%" title="+1" ></iframe></


Error: not well-formed
Source code:
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:g="http://base.google.com/ns/1.0"><body xmlns="http://www.w3.org/1999/xhtml"><section xmlns="http://www.w3.org/1999/xhtml"><div xmlns="http://www.w3.org/1999/xhtml"><aside xmlns="http://www.w3.org/1999/xhtml"><div xmlns="http://www.w3.org/1999/xhtml"><iframe allowtransparency="true" frameborder="0" hspace="0" id="I1_1333566712014" marginheight="0" marginwidth="0" name="I1_1333566712014" scrolling="no" src="https://plusone.google.com/u/0/_/pages/badge?url=https%3A%2F%2Fplus.google.com%2F100115770145624791433&size=badge&width=300&height=69&theme=light&hl=en-US&jsh=m%3B%2F_%2Fapps-static%2F_%2Fjs%2Fgapi%2F__features__%2Frt%3Dj%2Fver%3DaYArk5u26EQ.ja.%2Fsv%3D1%2Fam%3D!Ze6NnRS0VYCICGRMrA%2Fd%3D1%2Frs%3DAItRSTOL_oPDaC0zppkILB_GwftozqPEJg#id=I1_1333566712014&parent=http%3A%2F%2Fwww.html-5.com&rpctoken=723659509&_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart" style="position:absolute;left:-10000px;top:-10000px;width:300px;margin:0px;border-style:none" tabindex="0" vspace="0" width="100%" title="+1" ></iframe></
I'll investigate from urlclassifier side. Switching between versions could mean one or the other database is out of date (the format changed in the changesets you identified). 

The result of an urlclassifier hit would be expected to be an error page though, not a blank one. Also click vs urlbar enter doesn't matter for that.
Tracking for Firefox 12, but my read of input is that there aren't too many people running into this issue on FF11. We'll weigh risk vs reward when a fix is found.

https://input.mozilla.com/en-US/?q=blank+page&product=firefox&version=11.0&date_start=&date_end=
Assignee: nobody → gps
Keywords: reproducible
Assignee: gps → gpascutto
Reproducible for me, but I see nothing wrong in the UrlClassifier log and it even triggers when I disable it.

Works:
http://hg.mozilla.org/mozilla-central/rev/164976bffd31
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1 ID:20110909025538

I can reproduce the bug on this version. This isn't UrlClassifier. Also, we're down to Firefox 9 here, so this isn't a Firefox 11 issue.

I'm not sure what went wrong with the bisection. Maybe this is a threading/timing related issue, which would be affected by those UrlClassifier revisions? I'll try to bisect this too.
I've noticed slightly different symptoms with different pages on the HTML-5.com site, which IMO supports the theory that it could be related to timing / threading, and the difference between clicking on a link and entering the URL might also support that theory.  When testing a particular build it's probably necessary to check to see if among pages with a variety of timings, any of them have the problem.  This might also be a duplicate of other bugs where displaying a blank page seem to be more intermittent.
I can trace this back as far as Firefox 4.0b13:
Fails:
http://hg.mozilla.org/mozilla-central/rev/e273946b74c8
(In reply to Gian-Carlo Pascutto (:gcp) from comment #8)
> I can trace this back as far as Firefox 4.0b13:
> Fails:
> http://hg.mozilla.org/mozilla-central/rev/e273946b74c8

Given that, no need to track for FF12 specifically.
I bisected this a bit further, but I'm running into too many crashes in intermediate versions, and given that the bug isn't 100% reproducible, this is taking too much time.

I'm quite confident that this is not urlclassifier, based on it triggering with urlclassifier disabled and the logs being clean, and that the initial bisection was mislead by a small timing difference or something similar. 

Given that this bug seems to have been here for ages, I'm also clearing the regression flag.
Assignee: gpascutto → nobody
Component: Phishing Protection → Untriaged
Keywords: regression
QA Contact: phishing.protection → untriaged
No longer blocks: 669410
No longer depends on: 673470
So here's what seems to be another _different_ example of this weirdness.  When I go to the page at http://www.html-5.com/tags/xml-declaration/ and click on the link that says "polyglot" in the first paragraph, the URL in the address bar changes, but Firefox stays on the same "XML declaration" page.

The fact that what shows up on the Error Console seems to change on different days (today it's the same one error every few seconds) makes me wonder if Google keeps changing the code behind their "+1" button and if that's what's causing the issue.  If so, is there any way to make it such that Firefox will go ahead and display the requested page from the primary site even if there are errors coming from a third party site?
Hello Rob,

I just found this old Bug-report and saw, that there was never a final solution...
after some tests it WORKSFORME in actual FF31, but to be sure, i would be happy to get an feedback also from you before closing this Bug.

thanks for all your help.
Flags: needinfo?(Rob.Simpson)
Stephan,

Thanks. I checked in Firefox 31 in both Mac OS X and Windows and both the original issue with it showing a blank page and the other issue in Comment #11 with the page not rendering at all are no longer reproducible. Since some other comments indicated it looked like some kind of timing issue, it appears that either these issues have been fixed or the timing has changed enough that it no longer occurs on these pages, at least.

Thanks again.
Rob
Flags: needinfo?(Rob.Simpson)
Thanks, Rob.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.