Closed Bug 741618 Opened 8 years ago Closed 7 years ago

Implement MessagePorts

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 677638

People

(Reporter: markh, Unassigned)

References

Details

Both SharedWorkers (bug 643325) and MessageChannel (bug 677638) need MessagePorts - http://www.whatwg.org/specs/web-apps/current-work/#messageport.  ISTM we could probably refactor the queue stuff from dom/workers into a MessagePort and have both dedicated and shared workers use them.
OS: Windows Vista → All
Hardware: x86_64 → All
Both WebCore and V8 have implemented this.
FWIW, IE 10 implements ports as well; http://msdn.microsoft.com/en-us/library/ie/hh673525(v=vs.85).aspx

Also, now that <iframe sandbox> support has landed, MessagePorts/Channels are a good way to communicate with a sandboxed frame. `postMessage` has the disadvantage that the origin field of messages coming from the sandboxed frame are `null`, meaning that  frame navigation can change who you're talking to in ways that are difficult to detect. This would be a nice feature to have.
This is currently integrated with Bug 643325.
MessagePorts are happening in bug 677638
No longer blocks: 677638
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 677638
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.