android.database.sqlite.SQLiteDatabaseLockedException: database is locked at android.database.sqlite.SQLiteDatabase.native_setLocale(Native Method)

RESOLVED DUPLICATE of bug 746444

Status

()

--
critical
RESOLVED DUPLICATE of bug 746444
7 years ago
7 years ago

People

(Reporter: scoobidiver, Assigned: lucasr)

Tracking

({crash})

14 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

Attachments

(2 obsolete attachments)

(Reporter)

Description

7 years ago
It was hit by two users in 14.0a1/20120402031127: bp-b49c70fb-f69b-40d3-8e77-43a812120403.

android.database.sqlite.SQLiteDatabaseLockedException: database is locked
	at android.database.sqlite.SQLiteDatabase.native_setLocale(Native Method)
	at android.database.sqlite.SQLiteDatabase.setLocale(SQLiteDatabase.java:2115)
	at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:984)
	at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:956)
	at android.database.sqlite.SQLiteOpenHelper.getReadableDatabase(SQLiteOpenHelper.java:233)
	at org.mozilla.fennec.db.BrowserProvider.getReadableDatabase(BrowserProvider.java:882)
	at org.mozilla.fennec.db.BrowserProvider.query(BrowserProvider.java:1338)
	at android.content.ContentProvider$Transport.query(ContentProvider.java:192)
	at android.content.ContentResolver.query(ContentResolver.java:302)
	at org.mozilla.gecko.db.LocalBrowserDB.filterAllSites(LocalBrowserDB.java:168)
	at org.mozilla.gecko.db.LocalBrowserDB.getTopSites(LocalBrowserDB.java:189)
	at org.mozilla.gecko.db.BrowserDB.getTopSites(BrowserDB.java:121)
	at org.mozilla.gecko.AboutHomeContent.loadTopSites(AboutHomeContent.java:346)
	at org.mozilla.gecko.AboutHomeContent.access$400(AboutHomeContent.java:95)
	at org.mozilla.gecko.AboutHomeContent$9.run(AboutHomeContent.java:375)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=android.database.sqlite.SQLiteDatabaseLockedException%3A+database+is+locked+at+android.database.sqlite.SQLiteDatabase.native_setLocale%28Native+Method%29
9th topcrash on the list for 14a1.
Keywords: topcrash

Comment 2

7 years ago
This was fixed I guess. Only 1 crash in the last week and it's in a build from 04/02. Resolving as worksforme.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 years ago
(In reply to Sheila Mooney from comment #2)
> This was fixed I guess. Only 1 crash in the last week and it's in a build
> from 04/02. Resolving as worksforme.
With only about 800 ADU, you can't close a bug in Fennec because it doesn't happen during one week.

Here is a recent crash: bp-be0aa3e0-6da1-4aea-82e9-7d60f2120416.
Status: RESOLVED → REOPENED
Keywords: topcrash
Resolution: WORKSFORME → ---
blocking-fennec1.0: --- → ?
See also: bug 741224
Assignee: nobody → lucasr.at.mozilla
blocking-fennec1.0: ? → beta+
(Assignee)

Updated

7 years ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746444
(Assignee)

Comment 6

7 years ago
Created attachment 617767 [details] [diff] [review]
Add native function to force unlock on database file
Attachment #617767 - Flags: review?(blassey.bugs)
(Assignee)

Comment 7

7 years ago
Created attachment 617768 [details] [diff] [review]
Force unlock database file when database is opened in read-only mode
Attachment #617768 - Flags: review?(blassey.bugs)
(Assignee)

Comment 8

7 years ago
Comment on attachment 617767 [details] [diff] [review]
Add native function to force unlock on database file

Wrong bug, sorry.
Attachment #617767 - Attachment is obsolete: true
Attachment #617767 - Flags: review?(blassey.bugs)
(Assignee)

Comment 9

7 years ago
Comment on attachment 617767 [details] [diff] [review]
Add native function to force unlock on database file

Wrong bug, sorry.
(Assignee)

Comment 10

7 years ago
Comment on attachment 617768 [details] [diff] [review]
Force unlock database file when database is opened in read-only mode

Wrong bug, sorry.
Attachment #617768 - Attachment is obsolete: true
Attachment #617768 - Flags: review?(blassey.bugs)
(Reporter)

Comment 11

7 years ago
There are crashes in 14.0a2/20120429 after the fix of bug 746444 in Aurora.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 12

7 years ago
Scoobdiver, the patch for bug 746444 had a problem that got fixed in bug 749493. We should be watching for crashes after bug 749493 ships in Aurora.

Also, this bug is still a dup of bug 746444 anyway. Let's keep it that way.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746444
You need to log in before you can comment on or make changes to this bug.