The notification about preventing pop-ups is displayed when using "onmousedown" although the pop-up is actually opened

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: ioana_damy, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
20120328051619

STR:
1. Launch Firefox.
2. Load https://bug709448.bugzilla.mozilla.org/attachment.cgi?id=580628 in a tab.
3. Click on the "from mousedown" button.

The "Firefox prevented this site from opening a pop-up window" notification is  displayed although the pop-up has actually been opened. (the notification is not displayed when using "click", "setTimeout" or "mouseup")
For what I see, it seems to be Mac-only. At least, I can't reproduce that behavior on my Linux laptop but I can on a spare MacOS laptop. Do you have any Windows build around to check what's happening on Windows?
OS: All → Mac OS X
Version: 12 Branch → Trunk
Keywords: qawanted
(Reporter)

Comment 2

7 years ago
(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #1)
> For what I see, it seems to be Mac-only. At least, I can't reproduce that
> behavior on my Linux laptop but I can on a spare MacOS laptop. Do you have
> any Windows build around to check what's happening on Windows?

Mounir, if you look at the User Agents in comment 0, you will see that I have also reproduced this issue on Windows 7 and on Ubuntu 11.10 64-bit.
Keywords: qawanted
(Reporter)

Comment 3

7 years ago
(In reply to Ioana Budnar [QA] from comment #2)
> have also reproduced this issue on Windows 7 and on Ubuntu 11.10 64-bit.

To make it clear, Windows 7 was on 32 bits, Ubuntu 11.10 was on 64 bits. 

The issue reproduced constantly on both this OSs and on Mac 10.6.8.
Oh ok... a bit annoying if I can't reproduce that on my main laptop ;)
OS: Mac OS X → All
FWIW I can't reproduce on a current nightly on OSX. The "from mousedown" button doesn't display the file-picker, but does display the notification.
Indeed, I'm seeing what Jonas is seeing in comment 5.  

Which is the expected behavior, given:

  pref("dom.popup_allowed_events", "change click dblclick mouseup reset submit");

Note that mousedown is not listed there, so onmousedown does not allow popups.  So why are people seeing a popup on mousedown at all?
Oooh! I think I know what's going on here.

I can reproduce the "problem" reliably if I do the following:

1. Go to https://bug709448.bugzilla.mozilla.org/attachment.cgi?id=580628
2. Place mouse cursor over the "from mousedown" button
3. Press down mouse button (don't release it!)
4. See "Firefox has prevented popup" notification.
5. Note that page has scrolled down to make room for notificaion and that this
   caused mouse cursor to be located over "from mouseup" button.
7. Release mouse button.
8. See file-picker now getting opened.


So I don't think that any one action causes both the filepicker to be opened and the notification to be displayed. Instead the testcase just makes it easy to cause fileInput.click() to be called twice. Once for mousedown and once for mouseup. One of the clicks are blocked, the other opens the filepicker.

Resolving as invalid. Ioana, if this is not what you are seeing, please reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
I confirm that.
You need to log in before you can comment on or make changes to this bug.