Disk thrashing and high CPU util occurs on visiting certain sites, memory goes up

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Arthur K., Unassigned)

Tracking

SeaMonkey 2.9 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120328 Firefox/12.0 SeaMonkey/2.9
Build ID: 20120328234924

Steps to reproduce:

When visiting the link "6 Must-Have Products for Homeowners" (http://www.popularmechanics.com/home/reviews/news/new-must-have-products-for-homeowners) and then subsequently scrolling down to the "Related News" section and click on "50 Tools Everyone Should Own", my disk begins thrashing non-stop and the CPU spikes between 10-25% occur. If I do nothing and stay on the "50 Tools Everyone Should Own" page, the behaviors continues without stopping.

I should note that I noticed two other things: 1) the site icon on the page "6 Must-Have Products for Homeowners" flickers as if CTRL-R is being pressed and it's stuck in a state of perma-refresh. 2) Simply having this bug report page open and then switching back (Alt-Tab) to "6 Must-Have Products for Homeowners" stop the disk thrashing *instantly* but CPU becomes pegged at 99%.

STR:

1. Visit http://www.popularmechanics.com/home/reviews/news/new-must-have-products-for-homeowners and give it a few seconds to load fully.

2. On the same page, scroll down slightly and click the link to "50 Tools Everyone Should Own" in the "Related News" section.

3. All this page to load. Disk thrashing and CPU spiking should occur.

4. Additionally, CTRL-N to open a new window and Alt-Tab between the two  windows. When switching back to the link from Popular Mechanics, it *should* cease disk thrashing but CPU *should* be pegged at 99% utilization.

Additional note: If the disk is left to thrash for, say, 5 minutes, you will see memory utilization slowly creep up. Maybe a mem leak?


Actual results:

Disk thrashing occurs and CPU spikes happen.


Expected results:

Page should load normally and no CPU spikes or disk thrashing should occur.

Comment 1

6 years ago
I'm not seeing it - thrashing or spikes.

Or even the "50 Tools Everyone Should Own".

Suppose this is the page?:
http://www.popularmechanics.com/home/reviews/hand-tools/50-tools-everyone-should-own

but it looks to be devoid of expected content.
(Do you need to be logged in to see?)


How much memory do you have?
How much free disk space do you have?


If you restart in Safe Mode does the problem persist?
(Help | Restart with Add-ons Disabled)

If you further disable plugins, does the problem persist?
(Edit | Preferences | Advanced -> Scripts & Plugins => (uncheck) Suite)


> perma-refresh

Is not necessarily odd.

Comment 2

6 years ago
> I'm not seeing it - thrashing or spikes.

Well, mostly not.  Though I did see it once.
Didn't notice thrashing particularly, but CPU was stuck around 50%.

Can't seem to duplicate it though?

Originally I was testing with Aurora (2.10) & in Safe Mode & didn't see it.  Then I fired up a 2.9, with NoScript.  NoScript blocked the site.  I said Allow Globally (page refreshes), then I switched to a different PM page, & at that point CPU jumped.

Since then I haven't been able to duplicate?
(Reporter)

Comment 3

6 years ago
>I'm not seeing it - thrashing or spikes.
>
>Or even the "50 Tools Everyone Should Own".
>
>Suppose this is the page?:
>http://www.popularmechanics.com/home/reviews/hand-tools/50-tools-everyone-should-own

You cannot go directly to the 50 Tools Everyone Should Own link, it will not reproduce that way. You must use the steps I've written in STR, especially 1, and 2.

>but it looks to be devoid of expected content.
>(Do you need to be logged in to see?)

No need to be logged in. *If* you are able to click it, it should take you to another page which is without any specific content. In my case, I am not able to click it (50 Tools Everyone Should Own link) or right-click to open in new tab or window. Context menu disappear every time I right-click. It takes a few click to open the page.

>How much memory do you have?
2GB

>How much free disk space do you have?
20GB or 80GB (this is an older workhorse machine).

>If you restart in Safe Mode does the problem persist?
>(Help | Restart with Add-ons Disabled)

In Safe Mode I did not see the behavior. All I have as far as add-ons is AdBlock Plus 2.0.3 and FlashGot 1.4.1. Try with just my setup of AdBlock Plus, FlashGot, and SM 2.9b3 and omit NoScript as I do not have that add-ons. Thanx!
(Reporter)

Comment 4

6 years ago
Sorry, I meant SM 2.9b2, there is no 2.9b3.
(Reporter)

Comment 5

6 years ago
Well, I just installed SM 2.10a2 (Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120402 Firefox/13.0a2 SeaMonkey/2.10a2) and was able to reproduce with the same result. However, I am able to reproduce easier:

Newer STR:

1. Visit http://www.popularmechanics.com/home/reviews/news/new-must-have-products-for-homeowners and allow for the page to completely load. You may notice the link will change to http://www.popularmechanics.com/home/reviews/news/new-must-have-products-for-homeowners#slide-1. I don't think this is relevant but noting it all the same.

2. Once the page loads, you can do one of three things now:
    a. Minimize Seamonkey = disk thrashing and CPU spiking starts immediately
    b. CTRL-N to open a new window = = disk thrashing and CPU spiking starts immediately
    c. CTRL-T to open a new tab = disk thrashing and CPU spiking starts immediately

After typing for some time (currently in a new Tab), thrashing seems to have stopped but switching to the other tab (Tab 1) and back (Tab 2) causes thrashing and spiking to happen again.
I tried this in Nightly and Beta using the steps in comment 5, but I wasn't able to reproduce.
(Reporter)

Comment 7

6 years ago
Well, I am currently on Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120511 Firefox/13.0 SeaMonkey/2.10 and it is still happening. Currently thrashing and CPU is spiking though not as bad as with SM2.9.x. I brought up about:memory and it is slowly growing from 200MB to 300+ MB in only a few minutes time of thrashing and CPU spiking (9-18%, seems lower than was in 2.9.x).

Addons: Adblock Plus 2.0.3, Flashgot 1.4.4. With or without addons the behavior happens and is reproducible (for myself at least).

Is there some debug mode or console I can bring up that would give more detail as to what is happening when I trigger/reproduce this?
(Reporter)

Comment 8

6 years ago
Ok, I stand corrected. I hadn't tried to start in Safe Mode since 2.9 but now I tried with 2.10b1 and no more thrashing. Upon further investigation, it seems it must be something to do with Adblock Plus (ABP). When ABP is disabled but all other add-ons are enabled, no CPU spiking, no disk thrashing. Seems rather odd to me as ABP is a pretty well maintained add-on.

So do I now contact the ABP author to see if he can repro or...?
(Reporter)

Comment 9

6 years ago
Issue Report submitted to ABP author. Will update when I have more info or a response.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.