Last Comment Bug 742114 - GC: don't mark through type->interpretedFunction twice
: GC: don't mark through type->interpretedFunction twice
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 17:21 PDT by Terrence Cole [:terrence]
Modified: 2012-04-04 05:09 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (1.52 KB, patch)
2012-04-03 17:21 PDT, Terrence Cole [:terrence]
wmccloskey: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-04-03 17:21:28 PDT
Created attachment 612032 [details] [diff] [review]
v0

This appears to be a rebasing error.  I also re-ordered ScanTypeObject to match what's in MarkChildren.  I am not at all sure if this is okay, or if MarkChildren should have been the one to change: I did it this way to minimize the diff and because it matches the declaration order, not because I know which is most correct.
Comment 1 Marco Bonardo [::mak] 2012-04-04 05:09:33 PDT
https://hg.mozilla.org/mozilla-central/rev/471f17a5c405

Note You need to log in before you can comment on or make changes to this bug.