Last Comment Bug 742141 - Need to support the 'float' type in the WebIDL parser
: Need to support the 'float' type in the WebIDL parser
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
:
Mentors:
Depends on:
Blocks: ParisBindings
  Show dependency treegraph
 
Reported: 2012-04-03 19:26 PDT by Boris Zbarsky [:bz]
Modified: 2012-05-01 20:27 PDT (History)
1 user (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Maybe patch (1.68 KB, patch)
2012-04-03 19:26 PDT, Boris Zbarsky [:bz]
no flags Details | Diff | Review
Patch (8.24 KB, patch)
2012-04-30 05:04 PDT, Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
justin.lebar+bug: review+
Details | Diff | Review

Description Boris Zbarsky [:bz] 2012-04-03 19:26:43 PDT
Created attachment 612067 [details] [diff] [review]
Maybe patch

Right now, the parser dies on it.

Attached patch makes things work, but may be bogus.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-04-30 05:04:42 PDT
Created attachment 619526 [details] [diff] [review]
Patch

The "Maybe patch" fixes this, but it's a step in the wrong direction because it makes float consts more broken than they already are.  This patch doesn't make float consts any worse.
Comment 2 Justin Lebar (not reading bugmail) 2012-04-30 10:41:51 PDT
So FLOAT_ is the "float" keyword, while FLOAT is a floating-point literals?

If so, can we indicate in the token names which are keywords and which are literals, by putting a prefix / suffix on the names?  That would be helpful for sanity, I think.  (It looks like the spec does this, using "Literal" as a suffix for the literals tokens.)
Comment 3 Justin Lebar (not reading bugmail) 2012-04-30 10:45:53 PDT
Comment on attachment 619526 [details] [diff] [review]
Patch

r=me, but I'd really prefer for us to change to a saner set of token names.  But you can do that as a followup if you'd like...
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-04-30 11:27:23 PDT
Float and FloatLiteral sound good to me.  The *Literal stuff is pretty new in the spec, I think.

Note You need to log in before you can comment on or make changes to this bug.