Created attachment 612067 [details] [diff] [review] Maybe patch Right now, the parser dies on it. Attached patch makes things work, but may be bogus.
Created attachment 619526 [details] [diff] [review] Patch The "Maybe patch" fixes this, but it's a step in the wrong direction because it makes float consts more broken than they already are. This patch doesn't make float consts any worse.
So FLOAT_ is the "float" keyword, while FLOAT is a floating-point literals? If so, can we indicate in the token names which are keywords and which are literals, by putting a prefix / suffix on the names? That would be helpful for sanity, I think. (It looks like the spec does this, using "Literal" as a suffix for the literals tokens.)
Comment on attachment 619526 [details] [diff] [review] Patch r=me, but I'd really prefer for us to change to a saner set of token names. But you can do that as a followup if you'd like...
Float and FloatLiteral sound good to me. The *Literal stuff is pretty new in the spec, I think.
5 years ago