Last Comment Bug 742168 - ParisBindingsEnabled should be renamed
: ParisBindingsEnabled should be renamed
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Mac OS X
: P2 normal (vote)
: mozilla15
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
Depends on:
Blocks: ParisBindings
  Show dependency treegraph
 
Reported: 2012-04-03 20:50 PDT by Boris Zbarsky [:bz]
Modified: 2012-04-24 17:59 PDT (History)
4 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Maybe like so? (3.89 KB, patch)
2012-04-09 13:08 PDT, Boris Zbarsky [:bz]
peterv: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] 2012-04-03 20:50:38 PDT
Maybe ExperimentalBindingsEnabled(), since this pref will only control the moving edge of the conversion?
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2012-04-03 21:36:04 PDT
Shrug - I think Paris bindings is a fine way to refer to the "new dom bindings that aren't nodelists". I don't think it's any more confusing to have 'paris_bindings' control the moving edge of this stuff than it is to have 'new_bindings' control the moving edge of nodelist stuff.

I'm fine with changing it too - I just don't think it's really worth the effort.
Comment 2 Boris Zbarsky [:bz] 2012-04-03 21:39:44 PDT
I think this would be really confusing to new contributors, who would then start searching about for what the hecko this "Paris" thing has to do with anything and come up empty.

Note that I think the nodelist situation is also silly, naming-wise.  ;)
Comment 3 Boris Zbarsky [:bz] 2012-04-09 13:08:01 PDT
Created attachment 613363 [details] [diff] [review]
Maybe like so?
Comment 4 Peter Van der Beken [:peterv] 2012-04-16 03:24:04 PDT
I don't think the nodelist naming is silly personally, I think we should merge the two prefs instead after the next train.
Comment 5 Boris Zbarsky [:bz] 2012-04-18 09:17:35 PDT
https://hg.mozilla.org/projects/birch/rev/abc682ac7eee

That said, do we want to get this into 14, since it changes the pref name?

Note You need to log in before you can comment on or make changes to this bug.