Use the same code for determining size of SVG documents and other synthetic documents

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

unspecified
Firefox 15
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec11+)

Details

(Whiteboard: [not for 1.0])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
Created attachment 612104 [details] [diff] [review]
patch

+++ This bug was initially created as a clone of Bug #710126 +++

Web pages that are wider than they are long can't be viewed in full. This is especially an issue with images and presumably video.

Bug 710126 fixed this for image documents but not for other synthetic documents (video, and possibly SVG).  This patch should extend the same fix to work for all synthetic document types.  I haven't tested it yet.
Thanks for doing this, I had it on my to-do list. The only question I have about this if the SVG-specific code in Tab.getPageSize needs to be taken out with this change. If SVGs render properly centered without that code then we should take it out.
(Assignee)

Comment 2

6 years ago
Created attachment 612322 [details] [diff] [review]
patch v2

This works fine, although I'm not sure if it's fixing any real problems.  Videos seem to be rendered at the correct size/scale with or without this patch.  I can't reproduce bug 712065 with or without this patch, even if I back out the fix from bug 712065.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #612322 - Flags: review?(bugmail.mozilla)
(Assignee)

Comment 3

6 years ago
By the way, I think we should wait until after we've branched for our "1.0" native release before landing this, to avoid adding any risk for this non-critical fix.
Whiteboard: [not for 1.0]
(Assignee)

Comment 4

6 years ago
Created attachment 612344 [details] [diff] [review]
patch v2 (for real)

Forgot to hg qref.
Attachment #612104 - Attachment is obsolete: true
Attachment #612322 - Attachment is obsolete: true
Attachment #612322 - Flags: review?(bugmail.mozilla)
Attachment #612344 - Flags: review?(bugmail.mozilla)
Comment on attachment 612344 [details] [diff] [review]
patch v2 (for real)

Review of attachment 612344 [details] [diff] [review]:
-----------------------------------------------------------------

Agreed.
Attachment #612344 - Flags: review?(bugmail.mozilla) → review+
(Assignee)

Comment 6

6 years ago
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb238b1ab6dc

QA note: As mentioned in comment 2, this patch does not fix any reproducible bugs; it is just code cleanup at this point and it should not have any visible effects.
Summary: video documents wider than they are long can't be fully viewed → Use the same code for determining size of SVG documents and other synthetic documents
Target Milestone: --- → Firefox 15
Just to be clear, it would be good if QA verified that it has no visible effects when loading different types of documents (HTML, SVG, any image, video, etc.)

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/fb238b1ab6dc
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.