Last Comment Bug 742237 - Crash [@ nsMutationReceiver::NodeWillBeDestroyed] during GC
: Crash [@ nsMutationReceiver::NodeWillBeDestroyed] during GC
Status: RESOLVED FIXED
[sg:critical]
: crash, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: 325861
  Show dependency treegraph
 
Reported: 2012-04-04 02:07 PDT by Jesse Ruderman
Modified: 2012-04-10 10:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (crashes Firefox eventually) (242 bytes, text/html)
2012-04-04 02:07 PDT, Jesse Ruderman
no flags Details
stack trace (3.78 KB, text/plain)
2012-04-04 02:07 PDT, Jesse Ruderman
no flags Details
patch (949 bytes, patch)
2012-04-04 02:53 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Review
patch (979 bytes, patch)
2012-04-04 04:08 PDT, Olli Pettay [:smaug]
jonas: review+
Details | Diff | Review
patch (1015 bytes, patch)
2012-04-04 08:11 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Review

Description Jesse Ruderman 2012-04-04 02:07:15 PDT
Created attachment 612135 [details]
testcase (crashes Firefox eventually)

This testcase causes a crash during the next GC, or later.  Running with 
   MallocScribble=1 MallocPreScribble=1
helps make it crash during the GC rather than later.
Comment 1 Jesse Ruderman 2012-04-04 02:07:43 PDT
Created attachment 612136 [details]
stack trace
Comment 2 Olli Pettay [:smaug] 2012-04-04 02:35:00 PDT
Awesome!
Comment 3 Olli Pettay [:smaug] 2012-04-04 02:53:35 PDT
Created attachment 612139 [details] [diff] [review]
patch
Comment 4 Olli Pettay [:smaug] 2012-04-04 04:02:36 PDT
Comment on attachment 612139 [details] [diff] [review]
patch

er, silly me
Comment 5 Olli Pettay [:smaug] 2012-04-04 04:08:49 PDT
Created attachment 612145 [details] [diff] [review]
patch
Comment 6 Jonas Sicking (:sicking) 2012-04-04 08:07:53 PDT
Might be worth adding a comment to the extent of "do this last since it can cause us to be destroyed."
Comment 7 Olli Pettay [:smaug] 2012-04-04 08:11:21 PDT
Created attachment 612195 [details] [diff] [review]
patch
Comment 8 Olli Pettay [:smaug] 2012-04-04 09:00:12 PDT
https://hg.mozilla.org/mozilla-central/rev/d9678c14dea9

Note You need to log in before you can comment on or make changes to this bug.