Tab titles for all but active tab are blank!

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: jduell.mcbugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
I'm on nightly, Linux-x86-64.  As of yesterday, I restarted my browser and now all the tab titles are blank, except for the active tab.  As I change the active tab, it becomes the only tab with a non-blank title.

Favicons for the tabs are still showing.  See attached screenshot.

I've backed up my profile and done some experimenting.  First:  if I start with a fresh profile, I see tab titles fine.  No error.   Second: if I restart the browser several times with a copy of my original profile, the issue eventually gets fixed (took 2 or 3 tries, not just one), and after that, I don't see the issue any more (tried restarting 5-6 times, every time is fine).

I still have a backup copy of my profile that exhibits the bug.  It's large (550 MB), but I'd be happy to put it somewhere on a mozilla server (people?) if someone wants to look into this.   It has ~50 tabs open in the main panorama window, and several other smaller panorama tab sets.  (just tried switching tabs sets: I still see blank titles for the other, smaller tab sets).
Looks like the titles for background tabs are light grey.
Can you reproduce this in safe mode?
Reporter

Comment 3

7 years ago
> Can you reproduce this in safe mode?

As soon as I restart in safe mode the issue goes away.

I then tried resetting the profile back to the initial problem, then disabling my addons one by one.  All of my addons could be disabled and still showed the issue at restart *except* for Test Pilot 1.2.1.   Every time I disabled test pilot the problem was gone when I restarted the browser.  

Alas, I tried a new, empty profile, added just Test Pilot 1.2.1, and there's no problem.  So this is some interaction between my profile and Test Pilot.

Next steps?
Component: Tabbed Browser → Test Pilot
Product: Firefox → Mozilla Labs
QA Contact: tabbed.browser → test-pilot
Reporter

Comment 4

7 years ago
So this now happens to me even with all addons individually disabled (in safe mode it doesn't happen).  I can trigger it by trying to bookmark a page--all tab titles get greyed out (dolske tells me it's white on grey).

Mook suggested I delete my localstore.rdf file, and indeed, that seems to fix it.

Emailed copy of my old, offending localstore.rdf to dolske to inspect...
Component: Test Pilot → Tabbed Browser
Product: Mozilla Labs → Firefox
QA Contact: test-pilot → tabbed.browser
Reporter

Comment 5

7 years ago
Minor note: if I have multiple windows open, only the tabs in the active window are greyed out when I bookmark (and only the non-active tabs: the active tab stays ok)
Reporter

Comment 6

7 years ago
Seems like this will get fixed, if ever, by bug 559505
Depends on: 559505

Comment 7

7 years ago
> Seems like this will get fixed, if ever, by bug 559505
You had corrupt data in your local store, your localstore,rdf itself is fine. Why would whatever replaces localstore.rdf not store the same corrupt data (GIGO)?
(In reply to Jason Duell (:jduell) from comment #4)
> Mook suggested I delete my localstore.rdf file, and indeed, that seems to
> fix it.

(In reply to Philip Chee from comment #7)
> You had corrupt data in your local store, your localstore,rdf itself is
> fine.

R.Invalid
(Reopen (with details), if you disagree.)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.