Last Comment Bug 742537 - Remove HTMLMediaElement.initialTime
: Remove HTMLMediaElement.initialTime
Status: RESOLVED FIXED
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 11 Branch
: All All
: -- normal (vote)
: mozilla23
Assigned To: Andrew Quartey [:drexler]
:
: Maire Reavy [:mreavy]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 14:30 PDT by Chris Pearce (:cpearce)
Modified: 2013-05-17 13:18 PDT (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.16 KB, patch)
2013-03-30 14:23 PDT, Andrew Quartey [:drexler]
cpearce: review+
cajbir.bugzilla: review+
Details | Diff | Splinter Review

Description Chris Pearce (:cpearce) 2012-04-04 14:30:29 PDT
HTMLMediaElement.initialTime has been removed from the WhatWG HTML spec "since it doesn't have convincing use cases" so we should remove it too I guess.
Comment 1 Andrew Quartey [:drexler] 2013-03-30 14:23:41 PDT
Created attachment 731550 [details] [diff] [review]
patch
Comment 2 Chris Pearce (:cpearce) 2013-04-01 15:22:13 PDT
Comment on attachment 731550 [details] [diff] [review]
patch

Review of attachment 731550 [details] [diff] [review]:
-----------------------------------------------------------------

Can you also remove "TODO" the comments referring to initialTime in MediaDecoder.cpp and test_seekable.html please? Thanks.

Requesting additional review from doublec, so that this doesn't look like such an inside job. ;)
Comment 3 cajbir (:cajbir) 2013-04-01 16:13:23 PDT
Comment on attachment 731550 [details] [diff] [review]
patch

Review of attachment 731550 [details] [diff] [review]:
-----------------------------------------------------------------

Need to regenerate the uuid in the .idl file?
Comment 4 Andrew Quartey [:drexler] 2013-04-01 17:40:37 PDT
fixed nits and pushed to inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/88ff175d85fe
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-04-02 11:43:42 PDT
https://hg.mozilla.org/mozilla-central/rev/88ff175d85fe

Note You need to log in before you can comment on or make changes to this bug.