[QA blocker]: Japanese page/mail displays as blank squares

VERIFIED FIXED in M7

Status

()

Core
Internationalization
P1
blocker
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Erik van der Poel)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
** Observed with 6/1/99 Win32 build **
** This is observed only under Japanese Windows NT4 so far **
** These are not problems under US Windows NT **

I first noticed this problem with the Smoke tests for Intl Mail. There both
Japanese and UTF-8 messages showed as only as blank squares in thread pane,
message header and body. The UTF-8 message we use contains Japanese
characters.

When I checked Japanese web pages, I found that thereif the charset
selection and the web doc charset match, only square blanks were
displayed. For example, trying visiting the above page with the
encoding set to Shift_JIS -- you'll see squares.

Additional notes:

1. Korean page seems to be fine.
2. UTF-8 page seems to display OK.

For Mail messages:

1. Japanese message headers and body display squares
2. UTF-8 JPN header and body display as squares.

Comment 1

19 years ago
be aware that rickg switch to nsString2 one day before. Which may cause this
bug.
(Assignee)

Updated

19 years ago
Assignee: erik → nhotta
(Assignee)

Comment 2

19 years ago
The mail problem sounds like a mail problem. Reassigning to Naoki.

The charset selection vs Web doc charset matching issue sounds like a META
charset issue. Please reassign to ftang after fixing the mail bug.
(Assignee)

Updated

19 years ago
Assignee: nhotta → erik
Target Milestone: M7
(Assignee)

Comment 3

19 years ago
Sorry, I misunderstood Kat's comment. I thought he meant that if the selected
charset and doc charset did *not* match, then the characters showed up
correctly. Naoki just told me that this is not the case. So we probably have a
font problem on Japanese Windows. Reassigning back to myself.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

19 years ago
The problem of display exists also for Mail composer for
Japanese input. There is also Bug 7553 which refers to the
Editor display problem for Japanese input.
(Reporter)

Updated

19 years ago
Severity: normal → blocker
Priority: P3 → P1
Summary: Japanese page/mail displays as blank squares → [QA blocker]: Japanese page/mail displays as blank squares
(Reporter)

Comment 5

19 years ago
Sorting, Date/Format, JPN Mail composition -- these are all part of I18n M6/M7 objectives.
If this regression persists, there is no way to progress on these testing. I'm marking this bug as
a QA blocker.

Comment 6

19 years ago
I see the problem in my Winnt 4.0J.  However, when I tested this in the different Winnt 4.0J machine,
this does not happen.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
So far we have identified 2 machines where this problem occurs. Teruko's NT4-J and my NT4-J.
These are own main NT4-J test machines.

We have looked at other NT4-J machines (4 in all) but they did not exhibit this problem.

So far we have not been able to isolate a factor(s) which cause this problem. Both of
machines use Bitstream Cyberbit 1.1/2.0 but so do some of the machines we looked at.
Our service pack levels are 4 (teruko) and 3 (momoi), etc.

Updated

19 years ago
Blocks: 7228

Comment 8

19 years ago
*** Bug 7553 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

19 years ago
** Checked with 6/4/99 Win32 - 2nd build **

All areas where I reported this problem using my NT4-Japanese
machines are now trouble-free. I can see Japanese in UTF-8/JPN mail
msgs, Japanese mail composing as well as Japanese editing, and
Japanese web browsing.

This problem now seems fixed.
teruko, if you can see Japanese on your machine, please
mark this verified.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
I tested in 6-7-08 M7 build.  I could not see the Japanese as square anymore in Browser and Editor under my Winnt 4.0.
I marked this as verified.
You need to log in before you can comment on or make changes to this bug.