Closed Bug 742700 Opened 8 years ago Closed 8 years ago

Crash Report [@ java.lang.NullPointerException: at java.net.URI.parseURI(URI.java) ]

Categories

(Firefox for Android :: Android Sync, defect, P1, major)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
mozilla14
Tracking Status
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: AdrianT, Assigned: liuche)

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c0bebcaa-1058-4733-94ee-0bdc22120405 .
============================================================= 
java.lang.NullPointerException
	at java.net.URI.parseURI(URI.java:296)
	at java.net.URI.<init>(URI.java:72)
	at org.mozilla.gecko.sync.net.BaseResource.<init>(BaseResource.java:88)
	at org.mozilla.gecko.sync.net.BaseResource.<init>(BaseResource.java:80)
	at org.mozilla.gecko.sync.jpake.stage.DeleteChannel.execute(DeleteChannel.java:31)
	at org.mozilla.gecko.sync.jpake.JPakeClient.abort(JPakeClient.java:247)
	at org.mozilla.gecko.sync.setup.activities.SetupSyncActivity.onPause(SetupSyncActivity.java:153)
	at android.app.Activity.performPause(Activity.java:3901)
	at android.app.Instrumentation.callActivityOnPause(Instrumentation.java:1191)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:2459)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:2424)
	at android.app.ActivityThread.handlePauseActivity(ActivityThread.java:2404)
	at android.app.ActivityThread.access$1700(ActivityThread.java:124)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:979)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:123)
	at android.app.ActivityThread.main(ActivityThread.java:3806)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
	at dalvik.system.NativeStart.main(Native Method)

Steps to reproduce:
1. Open Nightly.
2. Go to Settings.
3. Open Sync.
4. Tap the hardware back button before the JPAK code.

Nightly/14.0a1
2012-04-05
Motorola Droid 2 ( Android 2.3)
Component: General → Android Sync
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Version: Firefox 14 → unspecified
I can reproduce this on my Galaxy Nexus albeit I had to be pretty aggressive on pressing the back button before the JPAKE code appeared (Nightly 04/05).
Keywords: reproducible
Whiteboard: [native-crash]
The issue is also reproducible if pressing the "Cancel" button instead of "Back". Also the issue is easier to reproduce on my Droid 2 where it takes around 20 seconds at least for the JPAKE to appear.
(In reply to adrian tamas from comment #2)
> Also the issue is easier to reproduce on my Droid 2 where it takes
> around 20 seconds at least for the JPAKE to appear.

That does not sound right. Please file a bug under this product and component regarding that.
Reason: the JPakeClient.channelUrl field is not yet filled when JPakeClient.abort is called, and it expects DeleteChannel to look at that value.

Chenxia, the fix here is to be more circumspect about when DeleteChannel is invoked; no need if a channel isn't being fetched, but if we started we should wait and cancel it.

This might require adding some shared "should abort" flag to JPakeClient to clean up when the channel fetch is done, or you might need to switch to using an executor queue or asynctasks instead of threads.

Should block release and/or beta.
Assignee: nobody → liuche
Severity: critical → major
Status: NEW → ASSIGNED
Priority: -- → P1
blocking-fennec1.0: ? → +
https://hg.mozilla.org/mozilla-central/rev/370a0a8ea1a2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed on:

Firefox 15.0a1 (2012-04-25)
Device: Samsung Galaxy S (Captivate)
OS: Android 2.2
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.