Last Comment Bug 742727 - [Azure] Azure-Thebes wrapper: Italic and underlined Text disappears for some fonts
: [Azure] Azure-Thebes wrapper: Italic and underlined Text disappears for some ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 14 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 743767
Blocks: 715768 738691
  Show dependency treegraph
 
Reported: 2012-04-05 07:59 PDT by Fanolian
Modified: 2012-05-20 13:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case (1.48 KB, text/html)
2012-04-05 07:59 PDT, Fanolian
no flags Details

Description Fanolian 2012-04-05 07:59:49 PDT
Created attachment 612542 [details]
Test case

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120405 Firefox/14.0a1

STR:
1. Set gfx.content.azure.enabled to True.
2. Open the test page.

Actual result:
For some fonts, italic and underlined text disappears. Even if the text reappears by highlighting them, the text color is different from expected.

Expected result:
Text does not vanish and is the same color as other samples.

The issue is not present if gfx.content.azure.enabled is set to false.

Last good: 2012-03-30
First bad: 2012-03-31
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=92fe907ddac8&tochange=4c43cfe73516

about:support
Graphics
Adapter Description    ATI Radeon HD 3600 Series
Vendor ID    0x1002
Device ID    0x9598
Adapter RAM    256
Adapter Drivers    aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version    8.951.0.0
Driver Date    3-8-2012 (Catalyst 12.3)
Direct2D Enabled    true
DirectWrite Enabled    true (6.1.7601.17776)
ClearType Parameters    Gamma: 2400 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200 
WebGL Renderer    Google Inc. -- ANGLE (ATI Radeon HD 3600 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows    1/1 Direct3D 10
AzureBackend    direct2d
Comment 1 timbugzilla 2012-04-05 14:11:57 PDT
Can reproduce. 

With azure on for content the text that is both italic and underlined disappears, and is return as green rather than grey when highlighted.
Comment 2 Alice0775 White 2012-04-09 05:28:23 PDT
Regression window(m-c)
Cannot reproduce
http://hg.mozilla.org/mozilla-central/rev/af214ef4172e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120329 Firefox/14.0a1 ID:20120330032922
Can reprodce:
http://hg.mozilla.org/mozilla-central/rev/0cfa44a13b25
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120330 Firefox/14.0a1 ID:20120330081422
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af214ef4172e&tochange=0cfa44a13b25


Regression window(m-i)
Cannot reproduce
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b90f61fffaf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120329 Firefox/14.0a1 ID:20120329114423
Can reprodce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1b468e61ac02
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120329 Firefox/14.0a1 ID:20120329115422
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b90f61fffaf&tochange=1b468e61ac02

Triggered by:
1b468e61ac02	Bas Schouten — Bug 738691 - Part 2: Add proper stroke and path support to Azure glyph drawing. r=jrmuizel
Comment 3 Fanolian 2012-04-11 13:31:46 PDT
I cannot reproduce it in 0411 build. Perhaps it is fixed by bug 743767 which also blocks bug 738691.

Please mark this as resolved if anyone can confirm it.
Comment 4 Alice0775 White 2012-04-11 13:45:16 PDT
Confirmed.
fixed by bug 743767

Note You need to log in before you can comment on or make changes to this bug.