Last Comment Bug 742780 - Turn off the debug mode by default for dom/system/gonk/systemlibs.js
: Turn off the debug mode by default for dom/system/gonk/systemlibs.js
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- trivial (vote)
: mozilla14
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 10:23 PDT by Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
Modified: 2012-04-12 23:27 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.84 KB, patch)
2012-04-05 10:24 PDT, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
no flags Details | Diff | Review
Patch v0.2 (3.34 KB, patch)
2012-04-05 10:47 PDT, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
kyle: review+
Details | Diff | Review

Description Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-05 10:23:23 PDT

    
Comment 1 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-05 10:24:08 PDT
Created attachment 612594 [details] [diff] [review]
Patch
Comment 2 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-05 10:47:37 PDT
Created attachment 612609 [details] [diff] [review]
Patch v0.2

Actually there is a if DEBUG that seems to not make sense too.
Comment 3 Kyle Machulis [:kmachulis] [:qdot] 2012-04-05 12:51:39 PDT
The systemlibs.js DEBUG guards seem dicey. Aren't we only going to be printing those when running from desktop b2g anyways? Wouldn't it be nice to know points where we're having to stub in libraries? Or are these causing print spam?
Comment 4 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-06 02:51:21 PDT
(In reply to Kyle Machulis [:kmachulis] [:qdot] from comment #3)
> The systemlibs.js DEBUG guards seem dicey. Aren't we only going to be
> printing those when running from desktop b2g anyways? Wouldn't it be nice to
> know points where we're having to stub in libraries? Or are these causing
> print spam?

Yeah that's only on desktop AFAIK. It's nice to know we have stubs in libraries but this is likely something you want to know when you're debugging an issue in this part of the code, otherwise it sounds just like print spam to me.
Comment 5 Kyle Machulis [:kmachulis] [:qdot] 2012-04-06 09:48:23 PDT
Comment on attachment 612609 [details] [diff] [review]
Patch v0.2

Eh, yeah, good point. It should probably be transparent if not on DEBUG mode.
Comment 6 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-04-11 10:06:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3b5a0a7c2dbc
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-12 10:24:06 PDT
https://hg.mozilla.org/mozilla-central/rev/3b5a0a7c2dbc
Comment 8 Philipp von Weitershausen [:philikon] 2012-04-12 23:09:09 PDT
This completely broke RIL and Wifi due to the double const. Please always test your patches on the device! I have fix ready, just testing on the device now to make sure.
Comment 9 Philipp von Weitershausen [:philikon] 2012-04-12 23:27:27 PDT
Fixed in https://hg.mozilla.org/mozilla-central/rev/10622eaff4fc

Note You need to log in before you can comment on or make changes to this bug.