touch.facebook.com Chrome Bar Overlaps Photo and Check-In Button on Fennec Native Nightly

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Steps:

1. Go to touch.facebook.com on fennec native
2. Login with a valid account

Expected:

The top chrome bar should render status, photo, and check-in equally separated from one another.

Actual:

See screenshot. Photo and Check-in buttons appear to be overlapping one another. This does not happen on webkit-based browsers with the same site.

Additional Notes:

Source code for that area is attached. For testing this, note that you cannot rely on changing the user agent on facebook, as facebook dynamically generates CSS based on the user agent to minimize dead code. 

CSS File Reference: https://s-static.ak.fbcdn.net/rsrc.php/v1/yr/r/D4PKpv2U8lb.css
(Reporter)

Comment 1

6 years ago
Created attachment 612745 [details]
Incorrect Table Layout Chrome Bar
(Reporter)

Comment 2

6 years ago
Created attachment 612747 [details]
Facebook Chrome Bar HTML Source
Chrome w/ WebKit 536.6 (@113237), exposes this exact issue too. It might be a width or display:block issue?
(In reply to Aaron Train [:aaronmt] from comment #3)
> Chrome w/ WebKit 536.6 (@113237), exposes this exact issue too. It might be
> a width or display:block issue?

And that is with the current Fennec UA: Mozilla/5.0 (Android; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0a1
(Reporter)

Comment 5

6 years ago
Aaron - Just checked on my Galaxy Nexus for Chrome on Android - I'm not getting a reproduction of this bug. What device are you using in comment 3 and comment 4? Are you changing the user agent on Chrome for Android?
Jason:

Can you tell me if you have font inflation enabled for fennec native? Navigate to about:config, search for 'inflation', and let us know what the values are for font.size.inflation.minTwips and font.size.inflation.emPerLine. If you change them both to 0, does the problem resolve?
(Reporter)

Comment 7

6 years ago
Values:

font.size.inflation.emPerLine: 0
font.size.inflation.minTwips: 120

Changing both to zero, I end up still seeing the same behavior specified in this bug.
Created attachment 613279 [details]
Chromium v20 w/ Fennec Nightly UA - Screenshot

(In reply to Jason Smith from comment #5)
> Aaron - Just checked on my Galaxy Nexus for Chrome on Android - I'm not
> getting a reproduction of this bug. What device are you using in comment 3
> and comment 4? Are you changing the user agent on Chrome for Android?

This was on Desktop (Chromium) using the current Mozilla Fennec UA in Nightly; see attached screenshot.
Blocks: 759986
(Reporter)

Comment 9

5 years ago
Looks like this is fixed now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Component: Layout: Tables → Evangelism
Product: Core → Firefox for Android
Version: 11 Branch → Trunk
(Assignee)

Updated

5 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
You need to log in before you can comment on or make changes to this bug.