Last Comment Bug 743179 - B2G SMS: error notification for REQUEST_GET_SMSC_ADDRESS failure is not fired
: B2G SMS: error notification for REQUEST_GET_SMSC_ADDRESS failure is not fired
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Vicamo Yang [:vicamo][:vyang]
:
Mentors:
Depends on: 727319
Blocks: b2g-sms
  Show dependency treegraph
 
Reported: 2012-04-06 01:00 PDT by Vicamo Yang [:vicamo][:vyang]
Modified: 2012-04-09 10:14 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
check options.type in REQUEST_GET_SMSC_ADDRESS handler (1.00 KB, patch)
2012-04-06 01:13 PDT, Vicamo Yang [:vicamo][:vyang]
philipp: review+
Details | Diff | Review

Description Vicamo Yang [:vicamo][:vyang] 2012-04-06 01:00:04 PDT
Bug 727319 add error notification for REQUEST_GET_SMSC_ADDRESS failure but it will actually never get fired for typo. The lines in REQUEST_GET_SMSC_ADDRESS handler:

  if (options.rilRequestError) {
    if (options.body) {

should be:

  if (options.rilRequestError) {
    if (options.fullBody) {

A better replacement might be checking `options.type == sendSMS` instead.
Comment 1 Vicamo Yang [:vicamo][:vyang] 2012-04-06 01:04:08 PDT
Note that bug 740238 tries to remove SMSC pre-fetching related code, and this bug just falls into its target range. Since it's still under review & verification on Akami, fixing this bug is still necessary for now.
Comment 2 Vicamo Yang [:vicamo][:vyang] 2012-04-06 01:13:44 PDT
Created attachment 612815 [details] [diff] [review]
check options.type in REQUEST_GET_SMSC_ADDRESS handler
Comment 3 Philipp von Weitershausen [:philikon] 2012-04-06 17:50:42 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/26a56a089f89
Comment 4 Matt Brubeck (:mbrubeck) 2012-04-09 10:14:34 PDT
https://hg.mozilla.org/mozilla-central/rev/26a56a089f89

Note You need to log in before you can comment on or make changes to this bug.