Lighting Filter clipped when kernelUnitLength specified

RESOLVED FIXED in mozilla14

Status

()

Core
SVG
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bill.seddon, Assigned: Robert Longson)

Tracking

Trunk
mozilla14
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 613097 [details]
Lyquidity.svg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I created an SVG document with three paths in three layers within a group: a drop shadow, the original text and an emboss layer with specular highlights.

I opened the file using FF 11 on Windows 7 (x64).  I opened it using both the file: and http: protocols.



Actual results:

The document renders correctly using Batik or in Chrome 17 but in FF 11 the emboss layer is not completely rendered exposing the text layer incorrectly.  The problem is hard to miss.


Expected results:

Should have been rendered correctly.
(Assignee)

Comment 1

5 years ago
Removing the kernelUnitLength attribute makes it render the way you want I think.
(Assignee)

Updated

5 years ago
Component: Untriaged → SVG
Product: Firefox → Core
QA Contact: untriaged → general
Summary: SVG document does not render correctly → Lighting Filter clipped when kernelUnitLength specified
Version: 11 Branch → Trunk
(Reporter)

Comment 2

5 years ago
Thanks for the prompt response> Yes, that works.
(Assignee)

Comment 3

5 years ago
Created attachment 613953 [details] [diff] [review]
patch
Assignee: nobody → longsonr
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #613953 - Flags: review?(roc)
Attachment #613953 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/709a9867cc31
Flags: in-testsuite+
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/709a9867cc31
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.