Last Comment Bug 743499 - [Azure] Asseration failed: (mCg) [@mozilla::gfx::DrawTargetCG::Init]
: [Azure] Asseration failed: (mCg) [@mozilla::gfx::DrawTargetCG::Init]
Status: RESOLVED FIXED
[qa+]
: crash, testcase
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla14
Assigned To: Jeff Muizelaar [:jrmuizel]
:
:
Mentors:
Depends on:
Blocks: 739506
  Show dependency treegraph
 
Reported: 2012-04-07 23:34 PDT by Christoph Diehl [:posidron]
Modified: 2012-05-21 06:51 PDT (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
wontfix
+
verified
-


Attachments
testcase (521 bytes, text/html)
2012-04-07 23:34 PDT, Christoph Diehl [:posidron]
no flags Details
callstack (11.48 KB, text/plain)
2012-04-07 23:35 PDT, Christoph Diehl [:posidron]
no flags Details
Handle negative sizes (605 bytes, patch)
2012-04-16 15:08 PDT, Jeff Muizelaar [:jrmuizel]
bas: review+
lukasblakk+bugs: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑central+
Details | Diff | Splinter Review

Description Christoph Diehl [:posidron] 2012-04-07 23:34:35 PDT
Created attachment 613161 [details]
testcase

In: /gfx/2d/DrawTargetCG.cpp:914

[...]
  mCg = CGBitmapContextCreate (mData,
                               mSize.width,
                               mSize.height,
                               bitsPerComponent,
                               stride,
                               mColorSpace,
                               bitinfo);
                   
 
  assert(mCg);
[...]
Comment 1 Christoph Diehl [:posidron] 2012-04-07 23:35:03 PDT
Created attachment 613162 [details]
callstack
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-04-16 10:54:12 PDT
I have no idea how common this is. See bug 745818 for tracking whether we want to turn off CoreGraphics for 12.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-04-16 15:08:39 PDT
Created attachment 615488 [details] [diff] [review]
Handle negative sizes

I didn't realize Sizes could be negative when originally writing this code.
Comment 4 Alex Keybl [:akeybl] 2012-04-18 11:04:03 PDT
Given https://bugzilla.mozilla.org/show_bug.cgi?id=745818#c10, we won't track for FF12.
Comment 5 Alex Keybl [:akeybl] 2012-04-18 15:36:03 PDT
And we'll wait for enterprises to let us know this is a major pain point before fixing on the ESR.
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-04-19 21:30:02 PDT
Comment on attachment 615488 [details] [diff] [review]
Handle negative sizes

[Approval Request Comment]
Regression caused by (bug #): 692879
User impact if declined: Occasional crashes
Testing completed (on m-c, etc.): test case attached to bug no longer asserts
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Comment 7 Alex Keybl [:akeybl] 2012-04-20 15:40:57 PDT
Comment on attachment 615488 [details] [diff] [review]
Handle negative sizes

[Triage Comment]
Very low risk, approved for mozilla-central.
Comment 8 Jeff Muizelaar [:jrmuizel] 2012-04-23 14:11:46 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ec09ab2b6e14
Comment 9 Ed Morley [:emorley] 2012-04-24 04:35:27 PDT
https://hg.mozilla.org/mozilla-central/rev/ec09ab2b6e14
Comment 10 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-25 12:36:47 PDT
Comment on attachment 615488 [details] [diff] [review]
Handle negative sizes

[Triage comment]
Please go ahead and land on Aurora.
Comment 11 Lukas Blakk [:lsblakk] use ?needinfo 2012-05-01 10:31:09 PDT
Comment on attachment 615488 [details] [diff] [review]
Handle negative sizes

[Triage Comment]
Sorry, this is meant for Beta, since it was after the merge.
Comment 12 Jeff Muizelaar [:jrmuizel] 2012-05-07 14:26:36 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/c059029404f8
Comment 13 Vlad [QA] 2012-05-21 06:51:22 PDT
I've verified this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20120517 Firefox/13.0 beta debug build

There is no assertion in the console and the build did not crashed.

Setting the flag to verified.

Note You need to log in before you can comment on or make changes to this bug.