Online/offline icon in status bar does nothing in Search Messages dialog

VERIFIED DUPLICATE of bug 80970

Status

VERIFIED DUPLICATE of bug 80970
18 years ago
10 years ago

People

(Reporter: cplyon, Assigned: sspitzer)

Tracking

({polish})

Trunk
x86
Windows 2000
polish

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Using build 2001040116 on Win2K

Steps to reproduce:
Open Search Messages dialog
Click on online/offline icon on the bottom left of the status bar

Results:
Nothing happens when clicked.
Not even a tooltip shows up when hovering over the icon.

Comment 1

18 years ago
Offline has not yet been fully implemented.  I believe this is really a
duplicate of bug 71581, where the mail window doesn't have offline switching
state capabilities yet.  When that is fixed, all mail windows should work or
then be looked at.  Calling this a duplicate.

*** This bug has been marked as a duplicate of 71581 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
QA Contact: esther → laurel
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Well, I see bug 71581 is now fixed, but that didn't help the offline indicator
in search messages ui. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, ui
(Reporter)

Comment 4

18 years ago
I noticed that the Manage Boomarks and the Search Bookmarks/History windows 
both have the same non-functional icon.  Should a seperate log be logged for 
these?
(Reporter)

Comment 5

18 years ago
As of build 2001050904 the online/offline icon on the Manager Bookmarks window
has been removed.

Should is simply be removed from Search Bookmarks/History and Search Messages as
well?

Comment 6

18 years ago
Chris, yes we should remove the Offline icon from Search [sspitzer and I talked
about this earlier today].

Taking bug.
Assignee: gayatrib → hwaara

Comment 7

18 years ago
Sigh. www.doisuckornot.com

All my attempts to hide the offline icon failed. I tried messing around with the
status* CSS classes, but none of them satisfied me...

Giving back to Seth... or, varada do you want this?
Assignee: hwaara → sspitzer

Comment 8

18 years ago
Since we're about to have offline search, do we want to hide this in the Search 
dialog (of course if it's going to be really hard to make this work in Search 
then I'm in favor of hiding it instead of having it show and not work)?

Comment 9

18 years ago
I think it would be better to show the icon and make it work (which should be
fairly trivial, especially if it just toggles the offline state). As you say,
Scott, since we have offline search, and some users would prefer us to search
the local database instead of the server and have control over that, and the
offline icon is an easy way to accomplish that.

Comment 10

18 years ago
You have two choices:
or
1. Use all the communicator overlays: communicator, security, tasks, utility.
   Note that this will cause the lock to appear which might be confusing.
or
2. Roll a new status bar instead of using Messenger's (c.f. Bookmarks):

Index: SearchDialog.xul
===================================================================
RCS file: /cvsroot/mozilla/mailnews/base/search/resources/content/SearchDialog.x
ul,v
retrieving revision 1.44
diff -u -r1.44 SearchDialog.xul
--- SearchDialog.xul    2001/06/26 07:08:17     1.44
+++ SearchDialog.xul    2001/06/28 14:28:45
@@ -172,6 +172,10 @@
        </box>
     </titledbox>
   </box>
-  <statusbar id="status-bar"/>
+  <statusbar>
+    <progressmeter class="progressmeter-statusbar" statusbar="true"
id="statusbar-icon" mode="normal" value="0" oncommand="dumpProgress()"/>
+    <statusbarpanel id="statusText" label="&statusText.label;" crop="right"
flex="1"/>
+    <resizer class="window-diagonal"/>
+  </statusbar>

 </window>

Comment 11

17 years ago
Doing a little cleanup. There couple of bugs all similar to
each other (this one and bug 79801). Seth made a more general
catch all bug (bug 80970).

So I'm going to mark this as dupe of bug 80970

*** This bug has been marked as a duplicate of 80970 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.